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EASY-ROB™ Operation References 

Introduction 

Overview of existing documents and Installation 

 

 
The Operation References will be a helpful assistant while working with EASY-ROB™. It contains detailed 
basic information which is required for to use all software features from beginning in proper way. 
 
The user will find information about the system files for the start configuration and the environment, 
description about short keys or the main dialogs as well as short tutorials. 
 
Please make sure that all documentation about EASY-ROB™ is available, to support you with the first 
steps. 
 
List of all existing documentation : 

- Product description 
(General description about all EASY-ROB™-products, options and API’s) 

- Operation References 
(How to use EASY-ROB™. Detailed description about system files, functions and dialogs) 

- EASY-ROB-ERPL 
(Reference for ERPL- and ERCL language) 

- TrainLib-Tutorial 
(Training manual)  

- Installation-Guidelines 
(Detailed description for the whole installation procedure) 

 
 
Make sure as well, that the following libraries are installed: 

- TRAINLib (library for training)  
(The Training library and the Tutorial will support the user on the first steps in EASY-ROB from an 
empty workcell to the simulation) 

- Tutorial folder with “Proj_example_erpl”  
(The examples will demonstrate how to use the ERPL- and ERCL language commands) 

 
 
Installation: 
To install EASY-ROB™ just use the document “Installation-Guidelines”. It describes in detail the whole 
installation procedure. 
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EASY-ROB™ Operation References 

Introduction 

Content of the Installation CD 

 

In the root folder you will find the installation setup programs for the following  
EASY-ROB™ Products 
 

• Installation-Guidelines.pdf Installation guidelines for EASY-ROB™ 

• EASY-ROB App Setup x64.exe EASY-ROB™ App Professional, Education Version 

• EASY-ROB LicenseManager Setup.exe EASY-ROB™ License Manager 

• EASY-ROB Viewer Setup x64.exe Free of charge EASY-ROB™ Viewer Version 

• EASY-ROB Demo Setup x64.exe Free of charge EASY-ROB™ DEMO Version 
Installation-Guidelines-DEMO.pdf with installation guidelines 
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Content of the installation CD 
 

 
Sub folder: 
 

• /Easy_Rob_EROSA EASY-ROB™ Open Software Architecture with  
 API Examples as Microsoft® Visual Studio 2017 
Project 

• /Easy_Rob_Kernel Examples and documentations for  
 EASY-ROB™ Kernel 

• /Easy_Rob_Updates Update archives for the following products 

o /Easy_Rob_Framework_Update EASY-ROB™ Framework 

o /Easy_Rob_LicenseManager_Update EASY-ROB™ License Manager 

o /Easy_Rob_App_Update EASY-ROB™ App Professional, Education Version 

o /Easy_Rob_Kernel EASY-ROB™ Kernel 

o /Easy_Rob_Viewer_Update EASY-ROB™ Viewer Version 

o /SystemFilesTemplate Templates for System Files (config.dat, easy-rob.pth, 
...) 

• /Easy_Rob_Viewerx64 Free of charge EASY-ROB™ Viewer Version 

• /EasyEdit-Offline-Programm-Editor EasyEdit™ a customized solution with  
 b+m surface systems GmbH (OLP for painting 
programs) 

• /Famos-Demoversion V9 Famos robotic® Demo version from carat robotic 
GmbH, uses the EASY-ROB™ Robotics Simulation 
Kernel 

• /Foxit-PDF-Reader Foxit PDF-Reader® to read PDF-Files 

• /Manual Examples and Descriptions as PDF files such as 
 Operation-References.pdf, EASY-ROB-
ERPL_ENG.pdf 

• /Options VRML-Examples.zip with examples to convert  
 VRML II,97 – files in to the IGP part file format with  
 subsequent optimization „merge“. 
 CAD-Import.zip: IGES-, STEP-, VRML-Import-
Examples 

• /Product-Info PDF-Documents for EASY-ROB™ Product Suite 

• /RobotLib Complete Robot Library 
 ABB, KUKA, Stäubli, Fanuc, Yaskawa 
 b+m, Comau, Mitsubishi, Universal Robots… 

• /SystemDlls Microsoft® Visual C++ Redistributable 2017 

• /TeamViewer TeamViewer for Presentation and Remote Support 

o TeamViewerQJ*.exe Starts EASY-ROB™ TeamViewer QuickJoin 

o TeamViewerQS*.exe Starts EASY-ROB™ TeamViewer QuickSupport 

• /WibuKey Installation Setup for WibuKey & CodeMeter Dongle 
Driver 
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EASY-ROB™ Operation References 

System Files 

The Environment File: easy-rob.env 

 

 
The environment file “easy-rob.env” contains all initial settings for the appearance of EASY-ROBTM and will 
be loaded automatically on each start of EASY-ROBTM. 
Additionally the user can load an environment file by an ERC command while a running simulation to 
change the settings. 
 
The file contains (e.g.) variables to set the  

- the floor states ON/OFF 
- the background color 
- the style of the toolbar 
- the clipping plane settings  
- etc.  

 
By having an “own” Environment File every user can start and use EASY-ROBTM with the personalized 
preferred settings. 
 
Changing the variables can be done on two ways:  

a) manually by editing the file  
b) saving the environment after changing the settings in the application 

 
To edit the file the user can use: 
 the shortcut : “Alt+Shift+E” 
 
 or the menu:    File menu ->Edit-> EASY-ROB System files->  „Environment file“ 
 
 
To save the environment by the menu after changing the settings in the application: 
 
 File menu ->Save-> „Environment file“ 
 
 
 
Remark:  
An exclamation mark ( ! ) in the beginning of a line in a System File stands for a comment line – you can put 
any comment behind it – the line will be skipped while reading. 
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Environment Variables 
 

Command and Syntax Valid Values Description 

FLOOR_ON 0; 1 switch the floor OFF / ON 

FLOOR_WIRE_ON 0; 1 switch the Floor  as wire frame OFF / ON 

FLOOR_LENGTH 0.100000 ….. 25.000000 length of the floor  [m] 

FLOOR_DLENGTH 0.100000 ….. 25.000000 length of one grid  [m] 

FLOOR_POSITION  X Y Z RX RY RZ 
X, Y, Z : +/- 0.000 ….. ~ 
RX, RY, RZ : +/- 0.00 …. +/-180.00 

position of the floor referred to world zero 
X,Y,Z [mm]; RX,RY,RZ [deg] 

Tip: 
Use this function to shift the floor if the zero of 
the workcell is not onto the floor.  

FLOOR_COLOR  0.0...1.0     0.0...1.0     0.0...1.0 color of the floor [R  G  B ] 
 
example: 
FLOOR_COLOR   0.6800   0.6850   0.6850 

BACKGROUND_COLOR  0.0...1.0     0.0...1.0     0.0...1.0 color of the background [R  G  B ] 
 
example: 
BACKGROUND_COLOR   0.0050   0.0000   
0.3200 

HITHER 0.020000 0.000500 ….. 4.000000 set the hither plane [m] 

YONDER 20.000000 1.000000 ….. 200.000000 set the yonder plane [m] 

VIEW_STEPS 20  1 ….. 100 set the view steps 

TOOLTIPS 0; 1 Switch tooltips OFF / ON, which appear by 
moving the cursor on a symbol. 

COI_ON 0; 1 Switch Center of Interest OFF / ON 

2_MOUSE_BUTTONS 0; 1 switch 2-Button Mouse OFF / ON  
 
Tip: 
Use 1 if your computer has only 2 mouse 
buttons. The middle mouse button is realized 
while pressing the left and right mouse button 
together. 

MONI_MSG_OUTPUT 0; 1 switch the Monitoring MSG OFF / ON 
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Environment Variables 
 

Command and Syntax Valid Values Description 

S3DM_MENU 0; 1 Space Mouse Menu OFF / ON 

S3DM_SPEED 1.0 Space Mouse Speed 

S3DM_THRESHOLD 1.0 Space Mouse threshold 

M_TO_UNIT 1000.000 mm  
1.000000 m 
39.370079 inch 

User defined Unit 
The internal EASY-ROBTM unit is “meter”. 
The variable “M_TO_UNIT” defines in which 
unit all the values will be displayed in EASY-
ROBTM 
(1m = 1000mm = 39.37inch) 
Example: 
M_TO_UNIT 1000.000000 mm   -> all will be 
displayed in “mm” 
M_TO_UNIT 39.370079 inch   -> all will be 
displayed in “inch” 
 
(see Menu -> View: ->Graphic View Data) 

REMOTE_MSG_OUTPUT 0; 1 remote messages in the message Window 
OFF or ON 

REMOTE_TRACE_FILE  REMOTE_TRACE_PRG.PRG if remote connection exists, the remote 
commands will be stored in the file. 

EXPORT_FILE  0; 1 creating a batch file OFF / ON   
 
(function to export all involved parts from 
workcell while saving, to make sure that all 
related parts are together e.g. for a data 
transfer)  

(see Operation References for details) 

ENABLE_RUNTIME 0; 1 RunTime-function for workcells OFF / ON  

TOOLBAR_MODE 2; 0; 1 change the toolbar style 
0-Standard Icons  
1-New Icons Normal 
2-New Icon Hot (this is the default value) 

SHOW_TAG_CONNECT 0; 1 connect all tags in current path OFF / ON, 

(see Operation References -Tag Window) 
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Environment Variables 
 

Command and Syntax Valid Values Description 

SHOW_TAG_TEXT 0; 1 display the name of all tags in the current 
path OFF / ON 

(see Operation References -Tag Window) 

TAG_APPROACH_DIREC
TION 

1;-1;2;-2;3;-3  1 use  x direction for picked normal 
-1 use -x direction for picked normal 
 2 use  y direction for picked normal 
-2 use -y direction for picked normal 
 3 use  z direction for picked normal 
-3 use -z direction for picked normal 

GRAD_BCKGND 0; 1 gradient background OFF / ON 

Recommendation: 
Set “GRAD_BCKGND 0” (OFF), if the 
graphic board is “below average” 

STOP_UNREACH 0; 1 stop on unreachable position OFF / ON  

(see Menu-> Simulation -> Run Settings) 

STOP_SWE 0; 1 stop on limit switch OFF / ON 

KEEP_IN_TRAVEL_RAN
GE 

0; 1 keep robot joints in travel range OFF / ON 

Assumption: 
1. axis 6 (rotZ) with limits swe=[-180,+180]; 
2. KEEP_IN_TRAVEL_RANGE set to ON (1) 
 
If the axis is rotating to e.g. “+181°”, the 
value will be set automatically to “-179°” to 
let the mathematic in the background 
calculate the angles in the limits. 
 
To let the mathematic in the background 
calculate the shortest angle to the previous 
joint angle, set the variable to OFF (0). 
 
The state (OFF) is default, because the 
second case is more common. 

STOP_SPEED 0; 1 stop on speed exceeding OFF / ON 

STOP_ACCEL 0; 1 stop on acceleration exceeded OFF / ON 

STOP_COLLISION 0; 1 stop on collision OFF / ON 
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Environment Variables 
 

Command and Syntax Valid Values Description 

USE_VBO 0; 1 Vertex Buffer Objects OFF / ON  (if 
supported by the graphic board)  
 
Remark: 
By using VBO the geometry will be loaded 
into the graphic board. To increase the 
rendering performance the geometry should 
be merged as well. 
VBO requires minimum OpenGL Version 1.5 
(check your settings in:    
Menu -> Aux -> Show current Settings) 
 
In case of trouble (even with OpenGL 
Version 1.5) set USE_VBO OFF. 

DISABLE_CROBOT_BBO
X 

0; 1 visualization of bBox for current selected 
robot OFF / ON 

DISABLE_3D_CAD_BBO
X 

0; 1 visualization of bBox for current selected 3D 
Cad object 

DISABLE_TOOLBAR 00000000 …. 11111111 switch toolbar OFF / ON 

Bit 0: forces to enable all available toolbars 
Bit 1: Load,Save toolbar 
Bit 2: Render toolbar 
Bit 3: Run toolbar 
Bit 4: OnOff toolbar 
Bit 5: 3DCad toolbar 
Bit 6: Move toolbar 
Bit 7: MouseMove toolbar 
 
Example 00010000 --> Bit 3 disables Run 
toolbar 
Example 01111110 --> shows MouseMove 
toolbar only 
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Environment Variables 
 

Command and Syntax Valid Values Description 

COLL_BODY_ROBOT 0; 1 collision all Bodies vs. all Robots OFF / ON 

(see Operation References - Collision)  

COLL_BODY_TOOL 0; 1 collision all Bodies vs. all Tools OFF / ON 

COLL_ROBOT_TOOL 0; 1 collision all Robot vs. its Tool OFF / ON 

COLL_GRAB_BODY_BO
DY 

0; 1 collision all grabbed Bodies vs. not grabbed 
Bodies 

COLL_GRAB_BODY_RO
BOT 

0; 1 collision all grabbed Bodies vs. all Robots 

COLL_ROBOT_ROBOT 0; 1 collision Robot itself 

COLL_BODY_BODY 0; 1 collision Bodies itself 

COLL_LINE_ENABLE 0; 1 collision line ON / OFF 

COLL_DETECCODE 0; 1; 2 Choice of Collision Detection Code 
0 – Load cell without collision 
1 - OpCode (only x86) 
2 - PQP „A Proximity Query PackageA 

TEXT SIZE 1 2 Change of text size and Tags (2. 
Parametres) 
1 - TYPE 10 SEMIBOLD ARIAL 
to 
8 - TYPE 24 SEMIBOLD ARIAL 

WORLD_COORSYS 0; 1 Switch World-Coorsys OFF / ON 

TAG_COORSYS 0; 1 Switch Paths and Tags OFF / ON 

ROBOT_COORSYS 0; 1 Switch Robot-Coorsys OFF / ON 

ROBOT_BASE_COORSY
S 

0; 1 Switch Robot-Base-Coorsys OFF / ON 

BODY_COORSYS 0; 1 Switch Body-Coorsys OFF / ON 

ROBOT_TCP_COORSYS 0; 1 Switch Robot-TCP-Coorsys OFF / ON 

IPO_COORSYS 0; 1 Switch temporary IPO-Coorsys OFF / ON 
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Environment Variables 
 

CRUISE_ROT_FLAGS LMB; MMB; RMB, SHIFT, CNTRL Button for Rotation of the world 

CRUISE_ZOOM_FLAGS LMB; MMB; RMB, SHIFT, CNTRL Button for Zoom 

CRUISE_ZOOM2MB_FLAGS LMB; MMB; RMB, SHIFT, CNTRL If „2 Mouse Button“ is deactivated in Aux 
menu -> „Mouse Mode“; Alternative 
solution for zoom 

CRUISE_PAN_FLAGS LMB; MMB; RMB, SHIFT, CNTRL Pan the World 

CRUISE_ROT_FLAGS_2 LMB; MMB; RMB, SHIFT, CNTRL, UNDEF Alternative solution: Button for Rotation 
of the world 

CRUISE_ZOOM_FLAGS_2 LMB; MMB; RMB, SHIFT, CNTRL, UNDEF Alternative solution: Button for Zoom 

CRUISE_PAN_FLAGS_2 LMB; MMB; RMB, SHIFT, CNTRL, UNDEF Alternative solution: Button for Pan 

CRUISE_COMMON_FLAGS DEFAULT Filtering Cruise Mouse Button 

DLG_TRANSPARENCY 0x1001  alpha; 
0x1002  alpha; 
0x1004  alpha; 
0x1008  alpha; 
0x1010  alpha; 

Presettings for dialogue-transparency. 
OFF: 0x1001 
Low: 0x1002 
Medium; 0x1004 
High: 0x1008 
User: 0x1010 

alpha = 100-255 
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EASY-ROB™ Operation References 

System Files 

The Config File: config.dat 

 

 
EASY-ROB requires the configuration file to start up. The configuration file "config.dat" will be loaded 
automatically on each start of EASY-ROBTM and contains 
 

- the path/location of your license file "license.dat" 
- the path of the temporary files 
- the path of the user files 
- Library paths and DLL names, used for API-User DLL Option 
- Your preferred Editor 

 
 
By having an “own” Config File every user can start and use EASY-ROBTM with the personalized preferred 
settings. 
 
 
Changing the file can be done manually by editing the file  
 
To edit the file you can use: 
 the shortcut : “Alt+Shift+C” 
 
 or use the menu:    File menu ->Edit-> EASY-ROB System files->  „Config file“ 
 
 
Remark:  
An exclamation mark ( ! ) in the beginning of a line in a System File stands for a comment line – you can put 
any comment behind it – the line will be skipped while reading. 
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Config File 
 

Command and Syntax Valid Values Description 

LICENSE= ..\ 
 
or full path  c:\......\........\ 

path for the License file 
default is the destination folder from 
installation 
”c:\program files\EASY_ROB\” 
 
(see also details LICENSE below) 

TMPDIR= Absolute and relative folder paths 
are allowed 

Consists file: 

- moni_msg.txt 

- Hardwarenumer.dat 

Example for path: 

TMPDIR=%USERPROFILE%\EASY-ROB\tmp  

Default is the destination folder of the 
installation 

USRDIR= Absolute and relative folder paths 
are allowed 

Consists file: 

- easy-rob.pth (new file)  
- easy-rob.env  
- easy-rob-localizationx64.ini  
- er_LoadFromLibPb.ini  
- er_LoadFromLibPb_prefered.ini  

Example for path: 

USRDIR=%USERPROFILE%\EASY-ROB 

Default is the destination folder of the 
installation 

LIBRARY_PATH= Absolute and relative folder paths 
are allowed 

path for the location of the UserDLL’s 
example: 
.\    is current folder 
..\    is folder one directory up 
“c:\home\my_er”  absolute folder 
 
default: LIBRARY_PATH= .\ 
 
(see also details API User DLL below) 

USER_DLL= “<name> <start option> <comment 
string>” 

name of the UserDLL 
 
(see also details API User DLL below) 

EDIT= any executable editor 
e.g. notepad, notepad++, ... 
 

Variable to set the preferred editor. 
Example: 
EDIT=notepad 
or 
EDIT= C:\program files\vim\gvim 

default: EDIT= notepad 
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Config File 
 

Command and Syntax Valid Values Description 

HELPFLN .\help.erh relative location of the help file 

ER_KIN_DLL= er_kinx.dll API-KIN, User defined name for forward and 
inverse kinematics 
x = „“ for EASY-ROB™ x86 Version 
x = „x64“ for EASY-ROB™ x64 Version 
x = „dll“ for EASY-ROB™ DLL Version 
x = „dllx64“ for EASY-ROB™ DLL x64 

ER_IPO_DLL= er_ipox64.dll API-IPO, User defined name for motion 
planning and execution 

ER_DYN_DLL= er_dynx64.dll API-DYN, User defined name for dynamics 
and control 

ER_POST_DLL= er_postx64.dll API-PostProcess, User defined name for 
PostProzessing 

ER_SENSOR_DLL= er_sensorx64.dll User defined name for Sensor Integration 

USR_OWNERKEY_DIR= Absolute and relative folder paths 
are allowed 

Directory of the OwnerKey file 

USR_OWNERKEY_FLN= Absolute and relative folder paths 
are allowed 

Name of the OwnerKey file 

 

mailto:info@easy-rob.com
http://www.easy-rob.com/


 

Subject to change or improve without prior notice 17/108 

  
EASY-ROB Software GmbH  Hauptstr.42  65719 Hofheim am Taunus  Germany  Phone: +49 6192 921 70-77  FAX: +49 6192 921 70-66  info.er@easy-rob.com  www.easy-rob.com 
 

Config File 
 

 

Details for variable “LICENSE” in Config file  
 
Every EASY-ROBTM product (except for the DEMO- and VIEWER-Version) requires a license to start up.  
 
The license is a text file with the name "license.dat" and will be provided by the purchase of the product. 
While installing the license file will be copied automatically to its default directory. 
 
 
When starting EASY-ROBTM , the program will search first into the Config file for the location of the license 
file. After that the program will check the given path and license file for validity. 
 
 
Note:  
 
While the standard installation the license file will be placed per default into the “destination folder”, which is: 
 
 C:\ Program Files \ EASY-ROB \ 
 
 while EASY-ROBTM software will be installed in folder 
 C:\ Program Files \ EASY-ROB \ EASY-ROB x64 \ 
 
 
 
Therefore the default value for the variable of the license is: 
 
 LICENSE= ..\ 
 
 
Recommendation: 
If you don’t use the default installation path or if you are going to change any of paths after installation, 
make sure that you verify the variable of the license file in the Config file. 
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Config File 
 

 

Details for variable “LIBRARY_PATH” and “USER_DLL“ in Config file  
 
The option API-UserDLL will adapt EASY-ROB™ individually to the users needs. 
Own dialogs can be developed and loaded automatically every time the user starts EASY-ROB™. 
 
The information for EASY-ROB™ which UserDLL has to be loaded and where to find it is located in the 
Config file. 
 
 
The variable for the location is named “LIBRARY_PATH” and defines the place where the UserDLL are 
located. 
 
Example: LIBRARY_PATH= .\ 
 
 
Valid values are absolute and relative folder paths e.g.: 
 
  .\  is current folder 
  ..\  is folder one directory up 
 c:\home\my_er   absolute folder 
 \\ws01\my_er  absolute folder 
 
 
 
The variable for the name of the UserDLL is “USER_DLL” and handles 3 parameter. 
 

1. the DLL name - e.g. "er_vad_exp01.dll" 
2. a digit for the start option  

”1” will start the dialog immediately when EASY-ROB™ starts up. 
"0" requires to start the UserDLL dialog from the View Menu-> API UserDLL Dialogs 

3. a user defined string will follow as comment 
 
 
example: USER_DLL= er_vad_exp01.dll 1 Api UserDll Expl_01 
  USER_DLL= er_vad_exp02.dll 1 Api UserDll Expl_02 
 
 
 
 
Note: 
If you don’t use the default location for the API-UserDLL in current folder and place it in another folder, you 
have to make sure, that all other DLL’s (required by the UserDLL) can be found  
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EASY-ROB™ Operation References 

System Files 

The License File: license.dat 

 

 
The license file “license.dat” contains the unique License key for all licensed products and the expiration 
date. 
 
You can open the file over the menue: 
 

File -> Edit-> EASY-ROB System files->  „License file“ 
 
 or by the shortcut : “Alt+Shift+L” 
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EASY-ROB™ Operation References 

System Files 

Monitoring Message File: moni_msg.txt 

 

 
The file „moni_msg.txt “ is monitoring general system information while an EASY-ROB™ session . 
 
Information like  

- the working directory 
- Date and Time 
- License Key 
- Enabled or Disabled option 
- location of the environment file and config file 

 
are the focus of the monitoring. 
 
 
The file can help the EASY-ROB-Support-Team in trouble shooting. In case of trouble you can send the 
monitoring message file to EASY-ROB to be analyzed. 
 
 
 
 
To view the moni_msg.txt file use the menue: 
 

File -> Edit-> EASY-ROB System files->  „moni_msg file“ 
 
 or the shortcut : “Alt+Shift+M” 
 
 
 
Tip: 
In case of time-consuming output while loading a work cell with a huge number of tag points, you can set 
the environment variable MONI_MSG_OUTPUT in “easy-rob.env” to [0]. 
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EASY-ROB™ Operation References 

System Files 

Preferred Paths File: er_LoadFromLibPb_prefered.ini 

 

 

Preferred Paths 
 
In addition to the automatically generated path history the Device Manager provides in the same Pulldown-
Menu the „preferred paths“. The list of „preferred paths” paths has to be created by the user and will be 
stored in the file „er_LoadFromLibPb_prefered.ini“.  

 
The basic file will be created once automatically if it doesn’t exist. The difference to the path history is, that 
the preferred paths won’t change and that enables the user to have a quick access to his 12 most important 
paths. 
 
The paths have to be written complete. 
Each line starting with an exclamation mark will be interpreted as a comment. 
 
 
Example: 
 

 ! 

 ! This file contains all your prefered/favorite paths 

 ! 

 ! All lines starting with "!" will be ignored 

 ! 

 ! Maximum numbers of paths is 12 

 !------------------------------------------------------ 

 ! 

 C:\Program Files\EASY-ROB\ApplicationLib 

 C:\Program Files\EASY-ROB\DeviceLib 

 C:\Program Files\EASY-ROB\RobotLib 

 C:\Program Files\EASY-ROB\Tutorial\Proj_example_erpl 

 ! 

 ! 

 
 
To edit the file, use the menu to open it: 
 

File -> Edit-> EASY-ROB System files->  „er_LoadFromLibPb_prefered.ini“ 
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EASY-ROB™ Operation References 

System Files 

Working Pathes File: easy-rob.pth 

 

 

Details for variable “WORKDIR” and “IGPDIR” in Config file 
 
In order for users to define their own work and geometry folders, which may differ from the user folders, the 
paths for these folders have been separated from the config.dat and will be managed in the future by the 
"easy-rob.pth" file. 
 
Paths for the work and geometry directories can also be set here by  

- WORKDIR=  

- IGPDIR=  

 
To keep the overview it is highly recommended that you keep all your projects separate in different libraries 
and that you keep a certain order inside the libraries. 
 
 
The philosophy for keeping data in EASY-ROBTM  is based on 2 directories.  
The working directory (WORKDIR) and the 3D CAD directory (IGPDIR). 
 
The working directory (WORKDIR) contains: 

- cell files (*.cel) 
- robot files (*.rob) 
- program files (*.prg) 
- view files (*.vie) 
- text files (*.txt), 
- bitmap files (*.bmp) 
- data files (*.dat) 
- JPEG (*.jpg) 

 
The 3D CAD directory (IGPDIR) contains all 3D geometry files such as: 

- *.igp 
- *.stl 
- *.wrl 
- *.stp 
- *.3ds 
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Working Pathes File 
 

 

Details for variable “WORKDIR” and “IGPDIR” in Config file 
 
To let EASY-ROBTM  know where to find the parts for a specific workcell, the WORKDIR and IGPDIR paths 
have to be declared in the Working Pathes File (easy-rob.pth). 
 
 Example: 
 WORKDIR= ..\ApplicationLib\ArcWelding 
 IGPDIR= ..\ApplicationLib\ArcWelding\igp 
 
By these given paths the system knows where to find the corresponding parts, programs, robots, etc. of a 
workcell. 
 
Note: 
Absolute and relative folder paths are allowed: 
  .\  is current folder 
  ..\  is a folder one directory up 
 c:\home\my_er   absolute folder 
 \\ws01\my_er  absolute folder 
 
 
Important Notice: 
An EASY-ROBTM  workcell- or robot-file (.cel /.rob) contains only a file name (plus the extension) of a 3D 
CAD geometry, but not its content! 
To find the specified file on the hard disk, memory stick or in a network, EASY-ROB will search in all below 
defined IGPDIR paths. Per default EASY-ROBTM  searches as well in a sub folder with the name .”\igp” of 
the loaded cell- or rob-file. 

 

Command and Syntax Valid Values Description 

WORKDIR= Absolute and relative folder paths 
are allowed 

Path for the working directory 
example: 
.\    is current folder 
..\    is folder one directory 
up 
“c:\home\my_er”  absolute folder 
“\\ws01\my_er”   absolute folder 
 
(see also details WORKDIR below) 

IGPDIR= Absolute and relative folder paths 
are allowed 

Path for the 3D CAD geometry 
example: 
.\    is current folder 
..\    is folder one directory 
up 
“c:\home\my_er”  absolute folder 
“\\ws01\my_er”   absolute folder 
 
(see also details IGPDIR below) 
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EASY-ROB™ Operation References 

System Files 

Localization File: easy-rob-localizationx64.ini 

 

 

Details for variables “en-US”, “de-DE” and “zh-Hans” 
 
The localization takes place under the menu point  
„File → Edit → EASY-ROB System Files → Localization file“  
and is achieved by excluding the undesired languages with a "!" before the lines. 
 

- en-US for English 
- de-DE for German 
- zh-Hans for Chinese (traditional)  

 
On the following page the German language was activated in the localization file. 
 

! EASY-ROB 3D Robot Simulation Tool 

! 

! EXE - Simulation Version x64 

! 

! Localization file 

! 

! "easy-rob-localizationx64.ini" 

! 

! Make sure that the localization Dlls exist 

! 

! Allowed language keys are 

! 

! en-US ==> EasyRobwx64ENU.dll (english) 

! de-DE ==> EasyRobwx64DEU.dll (german) 

! zh-Hans ==> EasyRobwx64CHS.dll (chinese) 

! 

! Note: '!' or ';' comment a line 

! 

!en-US 

de-DE 

!zh-Hans 

! 

 
The localization file easy-rob-localizationx64.ini is located in the installation directory of EASY-ROB™. 
 
If the localization DLLs do not exist, EASY-ROB ™ starts with English GUI, which is also the default 
setting. 
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EASY-ROB™ Operation References 

First steps with EASY-ROB™ 

Building an easy working cell with robot and tool 
 
 
First our simple working cell should consist of one robot with a tool. 
 

 
 

Loading a robot 

 
After launching EASY-ROB™ load 
the robot robot.rob from directory 
“.\Easy-Rob\TrainLib” by clicking 
Load Robot file in the File menu. 
 
The robot is now visible in the 
main window of EASY-ROB™. It's 
an articulated arm robot with six 
axes, thus a typical industry robot. 

Loading a tool 

 
The tool file tool.tol is loaded 
analogical by clicking Load Tool 
file in the File menu. 
 
 

Now save the intermediate result in a file named robot_tool.rob by clicking Save Robot file in the File menu 
and entering the filename in the dialog (Notice: The ending *.rob will be added automatically). 
 
Note: Files with the extension .rob can contain information about the robot as well as the used tool. 
 
Hint: You can also load files by directly pulling them from the Windows® -Explorer into the EASY-ROB™-
main window (Drag’n‘Drop). 
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First steps with EASY-ROB™ 
 

Navigating in the working cell and moving the robot 
 
Using the buttons shown to the right you can navigate in the working cell and move 
the robot. The first button is the navigation cursor which enables you to move in the 
world. The second and third button allows you to move the robot in tool- or world 
coordinates whereas the last button switches between translatory and rotatory 
motion. The button Robot Joints allows you to move the robot in axis coordinates. 
 
Note: Become familiar with these functions by selecting one of them and moving the 
mouse inside the EASY-ROB™-main window with mouse buttons held down. If you 
use a two button mouse you have to activate option 2 Mouse Buttons in the Aux / 
Mouse Mode menu and save the settings with File / Save / Environment file.  
 
Hint: Clicking twice on one of the buttons will show up additional functions and 
parameters. 
 

                    
 

Extending the working cell by adding a work piece 
 

 
 

Selecting the CAD-group 

 
In EASY-ROB™ 3D-CAD-data is classified in 
three groups.  
 
The Robot Group contains all data concerning 
the robot (e.g. the robot base or the muff).  
 
The Tool Group contains all data which can be 
assigned to the tool.  
 
Work pieces and all other geometries of the 
working cell are classified in the Body Group 
which you can select by the menu 3D-CAD / 
Select Group / Body Group. 
 
 
 
 
 
 

Note: EASY-ROB™ is no 3D-CAD-system but a robot simulation system. Only simple geometries such as 
cubes, cylinders, cones and spheres can be created and parameterized in EASY-ROB™. Therefore the 
modeling of more complex geometries must be done with a 3D-CAD-system. These geometries can then be 
imported into EASY-ROB™. To allow an efficient simulation the level of detail should be reduced. For 
performance reasons it's not advisable to show “every screw”. 
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First steps with EASY-ROB™ 
 

Adding a work piece 

 
By selecting 3D-CAD / Create/Import new 3D CAD 
Body / CUBE a new cube is created in the working 
cell. 
 
The position and orientation in the space will be set 
later. 

 

 
 

 
Now set up the bodies’ length (X) to 200 mm, the 
width (Y) to 300 mm and the height to 550 mm. 
 

 
 

 

 
 

 Afterwards name the body BOX. 
 
 
 
 

Positioning the work piece. 

 
In order to position the work piece select 
Enter Positions / World Position from the 
3D-CAD menu. 
 
The EASY-ROB™ Frame Dialog provides 
the option to define the position and 
orientation of the body in 6 degrees of 
freedom. 
 
Set up the bodies position as shown to  
X=450 mm, Y=300 mm and Z=0 mm. 

 

 
 

mailto:info@easy-rob.com
http://www.easy-rob.com/


 

Subject to change or improve without prior notice 28/108 

  
EASY-ROB Software GmbH  Hauptstr.42  65719 Hofheim am Taunus  Germany  Phone: +49 6192 921 70-77  FAX: +49 6192 921 70-66  info.er@easy-rob.com  www.easy-rob.com 

First steps with EASY-ROB™ 
 

Changing the color of the work piece 

 
To change the bodies color select 3D-CAD / Color. 
 

 

Save the current positions 

 
Save the current position of all robots and 
bodies in the workcell and define them as start 
positions. Select Simulation / Save Start 
Condition / Save all Robots Positions and 
Joints as Start Condition . 
 
You can also save specific positions of single 
bodies or robots by using the functions in the 
Menu. 
 
Hint: to reset all positions just use Simulation/ 
Reset Start Condition/ Reset all Positions and 
Joints as Start Condition.  
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First steps with EASY-ROB™ 
 

Saving the Workcell 

 
Save the current status of the workcell 
by using: File / Save Cellfile with the file 
name box.cell. 
 
 
 
 
If you confirm the next dialog “Reset all 
Positions and Joints to Start conditions“  
with “Yes” -  
everything in the workcell will be reset to 
the initial positions (that’s the position 
you stored in the previous step) 
 
Attention:  
If you confirm with „Yes“ but you did not 
store the positions like described above, 
an unwanted change of positions might 
occur  
Please note that there is no „Undo“-
button to cancel that. 
 
If you confirm the dialog with „No“ you 
can save the positions as start values at 
the end of the workcell saving 
procedure. 
 
 
 
Note: EASY-ROB™-working cells (files 
with the extension .cel) contain all 
information about the robot, the tool and 
work piece as well as references to 
possible robot programs. 
 
 
Hint: Working cells can also be saved 
by clicking the Save-Button in the 
toolbar. 
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First steps with EASY-ROB™ 
 

Creating working points (tag points) 
 

 

Tag-points (or teach-points) describe the position and orientation 
of working points that the robot should move to. 
 
Note: The tag-window is shown by a single click on 
the SEL TAG button. 
 

Task: 
 
A tag point should be created on all four upper corners of the 
cube (nr. 2 to 5). An additional tag point (nr. 1) should be defined 
as approaching point. 
 

 
  

Procedure for creating tag points 

 

 

Click once on the button New Tag on TCP. This will create a tag 
point at the tool tip (Tool Center Point: TCP). The tag point will 
show up in the tag point list. 
 
Now set up the position of the tag point T_1 to X=450 mm, Y=300 
mm, Z=700 mm and tit's orientation to Rx=0 degree, Ry=180 
degree and Rz=0 degree. 
 

 
 

Now activate the checkbox TCP Jog at the bottom of the tag window and the robot will move to the first tag 
point which means that the coordinate systems of the TCP and the tag point will be brought to congruence. 
 
Now click again on New Tag on TCP to create the tag point T_2. This one lies congruent with T_1. Move 
the tag point T_2 to a height of Z=550 mm. T_2 now lies on the first corner of the cube. 
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First steps with EASY-ROB™ 
 
Now create the tag point T_3 and set up its Y-coordinate to 600 mm. 
After that create T_4 with the X-coordinate set to 650 mm. At last create T_5 with Y=300 mm. 
 
The following table contains the position and orientation of all five tag points for checkup: 

 

Tag X [mm] Y [mm] Z [mm] Rx [deg] Ry [deg] Rz [deg] 

T_1 450 300 700 0 180 0 

T_2 450 300 550 0 180 0 

T_3 450 600 550 0 180 0 

T_4 650 600 550 0 180 0 

T_5 650 300 550 0 180 0 

 
Hint: For easier positioning you can use the functionality of 
EASY-ROB™  formula-parser. If a tag point lying on the height 
of Z=700 mm should be moved to Z= 550 mm just enter 700-150 
to the Z-field. 
 
If position and bearing of your tag points fit the values in the 
table, drive the robot to its home position and save the actual 
state as working cell in the file box_tags.cel. 
 
 
 

 

 
 

 
 

Note: The EASY-ROB™-cell files also contain the tag points. Furthermore the 
actual state of the robot is defined as home position. 
 
Hint: To move the robot to the tag points in the same order as they are shown in 
the list choose the first tag point and select Move Along. The type of motion that 
should be used to move the robot to the tag points can be defined with button 
Motion type in the TagWindow. 
 

 
 
Hint: The order of the tag points can be changed with the Up and Down buttons. 
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First steps with EASY-ROB™ 
 

Creating a PTP-robot program in EASY-ROB™ 
 
At first open the TeachWindow  
by clicking the corresponding button. 
 
Create a new program by click on New. Save the 
program as prg_ptp.prg by a click on the Save as 
button in the TeachWindow. Then save the cell in the 
file box_prg_ptp.cel. 
 
Note: The name of the EASY-ROB™-program will 
be saved in the working cell. The program will be 
automatically activated the next time you load the 
cell. 
 
 

Renaming the sub routine 

 
The values for the PTP-motion (Point-to-Point) 
should be stored in a function named sub_ptp. Get 
the program line call my_fct_name() into the edit line 
of the Teach Window by a double click on it and 
change it into call sub_ptp(). Pressing return will 
transfer the changed line back into the program. Now 
change the name of the function by changing the line 
fct my_fct_name() into fct sub_ptp(). 
 
 

 
 

 
 

Note: Programs can be created very comfortable in EASY-ROB™ by simple 
mouse clicks. All commands can be divided into the groups Motion, Cntrl and ERC. 
Make yourself an overview by clicking the corresponding buttons in the 
TeachWindow (> Motion,  > Cntrl,  > ERC). 

Inserting motion commands for PTP 

 
Commands are always inserted before the actual line so select the last program 
line endfct. At first the robot should move to its home-position. Insert the command 
Home 1 into the sub routine by clicking the Home-button in the Teach Window. 
 
Now open the TagWindow and select the tag point T_1. Press the button 
PTP cTag in the TeachWindow (cTag is the short form of current Tag, which 
means the currently selected tag point). 
 
Proceed for the tag points T_2 to T_5 in the same way. At last insert a motion 
command for T_2,  T_1 and back to the home position. 

Save the program by clicking the Save button in the TeachWindow. 
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First steps with EASY-ROB™ 
 

Executing the program 

 
The program can be started by clicking on the Run-button. The simulation speed can be 
changed with the Decrease Step size-(Ctrl + Shift + -)  and the Increase Step size-(Ctrl 
+) buttons. 
 
Hint: Press the Repeat-button if you want to repeat the program infinitely. 
 

 
 

 

 

Note: By pressing the Show Robot TCP Trace button the TCP-Trace will be displayed. 
 

 

Creating a LIN-robot program in EASY-ROB™ 
 

 
 

At first save the program as box_prg_ptp_lin.prg by 
pressing Save as- in the TeachWindow. Then save 
the cell as box_prg_ptp_lin.cel. 

Adding a sub routine for LIN 

 
The sub routine with the motion commands for LIN 
should be executed before the sub routine with the 
PTP-commands. Therefore select the line with the 
call sub_ptp() command. Now press >Cntrl in the 
TeachWindow and choose CALL FCT in the 
dialog. Enter sub_lin() as function name. EASY-
ROB™ will automatically insert a sub routine when 
you answer the following question with yes. 
 

 

Inserting motion commands for LIN 

 
Choose the program line endfct which closes the 
function sub_lin(). 
 
 
Now insert the commands Home 1 and PTP T_1 
because the robot should first move to the home 
position before moving to the first point by a PTP-
command. 

Now select T_2 to T_5 in the TagWindow one by one and press LIN cTag in the TeachWindow for each 
one. Don't forget to insert LIN-commands for T_2 and T_1 too. Finally the robot will be moved to the home 
position by the command line Home 1. 
 
Remember to save the program using the Save-button in the TeachWindow. 
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First steps with EASY-ROB™ 
 

  
 

That's how the complete program for LIN- and PTP-
motion looks like.  
 
Hint: Single motion commands can be executed by 
pressing the > Run Cmd-button in the TeachWindow 
(single step mode). Simply select the program line you 
want to be executed and press > Run Cmd. 
 

Comparison of PTP-motion and LIN-motion 
 
Compare the robots motion by activating the trace and 
executing the sub routine with the PTP-commands and 
afterwards executing the LIN-command-sub routine in 
single step mode. After executing the PTP-sub routine 
change the trace color to blue by choosing View / TCP 
Trace / Color / Color for desired TCP TRACE. from the 
EASY-ROB™ main menu. 
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First steps with EASY-ROB™ 
 

Adjusting the motion speed and acceleration 
 

 

 
 

Make sure that the motion planners for PTP-, CP- 
and CIRC-method are set to Jerk free Vel-Prof. C3. 
This setting can be made in the Robotics / Robot 
Motion Planner menu. 
 
Note: Motion planners and speeds are divided into 
PTP and CP. CP is the short form for Continuous 
Path which means driving a course as with LIN or 
CIRC. 
 
Save the program as box_prg_ptp_lin_speed.prg by 
pressing the Save as Button in the TeachWindow and 
save the new cell as box_prg_ptp_lin_speed.cel. 
 

Setting up SPEED and ACCEL 

 
By pressing > Cntrl-Knopf in the TeachWindow you 
gain access to the commands for setting up speed 
and acceleration (SPEED and ACCEL). 

Set up the values for SPEED and ACCEL by 
pressing the appropriate buttons according to the 
following table: 
  

ACCEL_ORI 
 
40  2

deg

s
 

  
ACCEL_CP 

 
1.500  2s

m
 

  
SPEED_ORI 

 
5  

s

deg
 

  
SPEED_CP 

 
0.050 

s

m
 

  
ACCEL_PTP_AX 

 
40 40 40 40 
40 40 

2

deg

s
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SPEED_PTP_AX 

 
5.0 5.0 5.0 
5.0 5.0 5.0 

2

deg

s
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First steps with EASY-ROB™ 
 

 
 
 

Note: In contrast to the SPEED- and ACCEL-dialogs length values in 
EASY-ROB™ robot programs are declared in meters instead of 
millimeters. 
 

Verifying the result 

 
Show up the Robot IO Output-dialog using the toolbar and choose the 
entry current Motion Data from the list. Now you will get information 
about the duration of the simulation, the duration of the robot motion 
and the duration of the last motion set. Furthermore the actual values of 
velocity and acceleration are displayed. 

Extending the program 
 
Save the program as prg_ptp_lin_speed_track.prg and the cell as 
box_prg_ptp_lin_speed_track.cel. 
 

Modifying the track in the robot program 

 
The visualization of the TCP Trace can directly be switched on 
and off in the EASY-ROB™-robot program. Furthermore you can 
change the color of the track. Just insert the yellow marked lines 
in your program. To do so press > ERC in the  TeachWindow and 
choose the option ERC [] ON. Afterwards click TRACK. To change 
the color choose the option ERC COLOR []. After selection of 
COLOR TRACK you can choose your color. 
 

Inserting a break 

 
Duration bounded breaks can be realized with the WAIT-
command followed by the duration in seconds. The next command 
will be executed after that time. The time means simulation time 
not real time. 
 
Hint: Try the effect by executing the program with and without the 
WAIT command and watch the simulation time. 
You can comment out a program line by inserting a leading 
exclamation mark. 
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EASY-ROB™ Operation References 

Short Keys and startup options 

 
 
The EASY-ROB™ user interface can be operated by mouse or by keyboard using short keys. The following 
list gives an overview over the existing short keys. 
 
EASY-ROB™ - Start with option and command list 
 
Examples: 
 
easyrobw.exe .\proj\Zelle.cel -run -io  Loads the cell file "Zelle.cel", launches automatically the 

program contained in the cell and opens the output window for 
the joint angles of the robot or NC machine. 

 
easyrobw.exe -remote -info  Opens the remote control dialog and the message window 

after start-up. 
 
easyrobw.exe -toolbarsoff - statusbaroff  Launches without toolbars and status bar 
 
easyrobw.exe -loadlib  Opens the Load Library dialog 
 
easyrobw.exe -prog  -teach   Opens the Program- and Teach Window  
 

 
EASY-ROB™ user interface 

COMAU Industrial robot SM5-PAL-260-3.1 
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Short Keys and startup options 
 

Button or menu 
key combination / 
option 

function 

 

 

Toggle Light 
 

-light 3D scene displayed without light source 

 

 

Toggle Point, Vertices 
 

Ctrl + P 
-point 

3D-geometries displayed as vertices 

 

 

Toggle Wire Frame 
 

Ctrl + W 
-wire 

3D-geometries displayed as wire frame 

 

 

Toggle BBox 
 

Ctrl + B 
-bbox 

3D-geometries displayed as bounded boxes 

 

 

Toggle Backface Culling 
 

Ctrl + Shift + B 
-bface 

Back face culling 

 

 

Toggle Floor 
 

-flooroff Switch off visibility of the floor 

 

 

Floor Position 
 

-floorwire Display the floor as wire frame 

 

 

Open avi recorder dialog 
F6 Open AVI recorder 
dialog 

Starts AVI Recorder Dialog  

 

 

Toggles: Simulation View 
or CAD-Preview 
 

Ctrl + Tab Switch between simulation and preview 

 

 

 

Run Program 
 

Ctrl + R 
-run 

Run the actual program 

 
                              Pause/Continue 
 

 Continue / pause program execution 

 

 

Abort Program 
 

 Stop program execution 

 

Stops program execution 
after each motion 
command 

 
Automatic stops program execution after 
each motion command 

 

Repeats program 
automatically 

-runrepeat Automatic program repeat 

 
3D Animation On/Off  

Enables/Disables 3D-Animation while 
simulation 

 

 

Decrease Stepsize 
 

Ctrl + '+' Decrease simulation step size 

 

 

Increase Stepsize 
 

Ctrl + Shift + '-' Increase simulation step size 
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Short Keys and startup options 
 

 

Display miscellaneous 
output values 

-io -io2 -io3 -io4 
Opens the first 4 Output-dialogues 
(desired Joint Values, desired Cart. Pose, 
current Motion Data, actual  Joint Values) 

 

Button or menu 
key combination / 
option 

function 

 
File → Load → Cell file 

Ctrl + O 
-loadcel 

Load a cell file 

File → Load → Robot file -loadrob, -loadrobot Load a robot file 

File → Load → Tool file -loadtol, -loadtool Load a tool file 

 

File → Load → Load from 
Library 

Ctrl + Shift + O 
-loadlib 

Load a cell, robot, tool, etc. from the library 

 File  → Load → Start  
 Project Manager 

Ctrl + Shift + P Start the Projectmanager 

 File  → Load → Start  
 ERC Searcher 

Ctrl + Shift + S Start the ERC Searcher 

 File  → Load → Start  
 History Diagram 

Ctrl + Shift + H Start the History Diagram 

 File  → Load → Start  
 CAD2ER Converter 

Ctrl + Shift + C Start the CAD2ER Converter 

 
File → Save → Cell file Ctrl + S Save / Save as of the cell file 

 File → Unload → Cell Ctrl + U Unload a workcell 

File → Edit → EASY-ROB System 
Files → Config file 

Alt + Shift + C Edit the file config.dat 

File → Edit → EASY-ROB System 
Files → Environment file 

Alt + Shift + E Edit the file easy-rob.env 

File → Edit → EASY-ROB System 
Files → License file 

Alt + Shift + L Edit the file License.dat 

File → Edit → EASY-ROB System 
Files → Moni_msg file 

Alt + Shift + M Edit the file moni_msg.txt 

File → Exit 
Ctrl + F4, 
Alt + F4 

Close EASY-ROB 

? → Online Help F1  Show online help 

? → License Info -licenseinfo License information 

? → About... -about Shows the "about"-dialog 

 

Simulate →Programs →  
Teach Window 
Open Prgram Teach 
Window 

-teach Opens the teach dialog 

 

Simulate →Programs →  
Progam Output 
Show Program Window 

-prog Opens the program dialog 

 

(2x) Tags →Tag Window  
 

-tag Opens the Tag Window 
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Short Keys and startup options 
 

 

 

(2x) 3D-CAD → 3D-CAD 
Window 

-3dcad Opens the 3D-CAD dialog 

 

Button or menu 
key combination / 
option 

function 

 
 

 

View → Coorsys → 
Show Robot Coorsys 

-robcoorsys 

Show coordinate systems on robot joints 
 

  

View → Message Window 
Ctrl + M, 
-message 

Open message dialog (information output) 

View → Navigator Window Ctrl + N 
Open navigator dialog (Pick & Click, 
distance measuring, etc.) 

View → Status Bar -statusbaroff Hide program status bar 

View → Coorsys → Show Robot 
Coorsys 

-robcoorsys 
Show the coordinate systems in the axis of 
the  Robot 

View → EASY-ROB PlugIn Dlls → 
Avi Recorder 

-avi 

Open AVI recorder dialog 

 

View → Show Toolbars → All 
Toolbars On 

Ctrl + T 
-toolbaron 

All tool bars on 

View → Show Toolbars → All 
Toolbars Off 

Ctrl + Shift + T 
-toolbaroff 

All toolbars off 

View → Show Toolbars → 
Load/Save 

-toolbarloadsaveoff "Load / Save"-toolbar off 

View → Show Toolbars → Render -toolbarrenderoff Render Toolbar off 

View → Show Toolbars → Run/ 
Animation 

-toolbarrunoff Run Toolbar off 

View → Show Toolbars → On/Off -toolbaronoffoff On/Off Toolbar off 

View → Show Toolbars → 3DCAD -toolbar3dcadoff 3D CAD-Toolbar off 

View-> Show Toolbars-> Move 
Robot to 

-toolbarmovetooff Move to Toolbar off 
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View → Show Toolbars → Mouse 
Mode 

-toolbarmouseoff Mouse Move Toolbar off 
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Short Keys and startup options 
 

Button or menu 
key combination / 
option 

function 

View →Show Toolbars → Robot 
Toolbar 

-toolbarselectrobot Robot Toolbar off 

Robotics → Robot Application → 
Remote Control 

F2 
-remote 

Open remote control dialog 

Robotics → Robot Application → 
External Devices → Sensor 
Interface 

F3 
-sensor 

Open sensor interface dialog 

View → EASY-ROB PlugIn Dlls 
Vrml97 Export 

F7 Start VRML97 Export Dialog 

View → Set 3D Views → Goto 
next Simulation View 

Ctrl + Tab Switch to next Simulation-View 

View → Set 3D Views → Goto 
prev Simulation View 

Ctrl + Shift + Tab Switch to previous Simulations-View 

 

3D CAD → Attributes → Info Ctrl + I 
Geometry information for the actual CAD-
object 

3D CAD → Cad Preview Settings 
→ Info 

Ctrl + Shift +I 
Geometry information for the CAD-object in 
the preview 

 

 
 

 

 
Spacebar/ Leertaste 

 
 

 
→ 
 
 
 

→ 

 
Toggles between the previous and the 
actual mouse mode 
 
WorldView  →  Jog Robots TCP Tool 
Jog Robots TCP Tool  →  WorldView 
 
 

Aux → EASY-ROB Client Window -client 
Opens an additional EASY-ROB™ session 
with the same cell file.. 

 
Aux → Mouse Mode → TCP Tool 
 
Aux → Mouse Mode → Abs | Rel 
 
Aux → Mouse Mode→ Rot | Trans 
 

 

MouseMode   
 
 
Shift     →  
 
 
Ctrl      → 

If the mouse mode "Tcp Tool" is active you 
can toggle between translatory / rotatory 
movement by pressing Shift and between 
absolute / relative movement by pressing the 
Ctrl-key. 
 
Status bar   
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Aux → Mouse Mode → TCP World 
 
Aux → Mouse Mode → Abs | Rel 
 
Aux → Mouse Mode→ Rot | Trans 
 

 

MouseMode 
 
 

Shift     → 
 
 

Ctrl       → 

If the mouse mode "Tcp World" is active you 
can toggle between translatory / rotatory 
movement by pressing Shift and between 
absolute / relative movement by pressing the 
Ctrl-key. 
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Short Keys and startup options 
 

Button or menu 
key combination / 
option 

function 

Aux → Mouse Mode → Joint 
 
 

 
 

 
 2 x  
 

 
 
 
 
 
MouseMode   
 

 
 
ESC 
 
Ctrl 
 

 
 
 
 
 
 
 
ESC resets the joint angles 
 
Pressing Ctrl while moving the mouse 
switches to the axes 4-6. Releasing the key 
switches back to axes 1-3. 
 
 
Clicking twice on  
launches the JogWindow dialog 

Aux → Mouse Mode  → World 
View 
 

 
 

 

 Cruise Mode Auswahlmöglichkeiten 

  
 
 2 x  
 
 

 
 
 
MouseMode   
 

 
 
ESC 
 
 
 
 
 
 
 
 
 
 
 
Ctrl-Key 
 
 
 
 
 
Shift-Key 
 

If the mouse mode "World View" is active 
you can toggle the camera perspective by 
pressing TAB. 
 
ESC resets the 3D view. 
 
 

Clicking twice on  
 
launches the Navigator dialog (Pick & Click, 
distance measuring, etc.) 
 
In the navigator window the cruise mode that 
the 3D scene will rotate around can be set.  
 
 
 
When pressing Ctrl the cruise mode is set to 
Robot TCP. Then the actual rotation center 
is the TCP of the robot. 
 
If a vertex, polygon or tag was previously 
selected with Pick & Click and this shall be 
the rotation center, then press the Shift Key. 
The cruise mode will then be set to „picked 
Point“ and your selection is the rotation 
center of the 3D scene. 
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Short Keys and startup options 
 

Button or menu 
key combination / 
option 

function 

 
Aux → Mouse Mode → Trans/Rot 
current selected Tag 

 

 
 

  2 
x  
 
 
 

 
 
 
 
 

MouseMode 
 
 
Shift      → 
 
 
Ctrl        → 
 
 
Arrow UP 
Arrow Down 
 
Pos 1 (home) 
Ende (end) 
 
ESC 

If the mouse mode "Tag" is activated you 
can toggle between translatory / rotatory 
movement by pressing Shift and between 
absolute / relative movement by pressing the 
Ctrl-key. 
Absolute: motion in relation to Wobj-frame 
Relative: motion in the tag frame 
 
 
Pressing Arrow UP and Arrow DOWN 
selects tag points. 
The name of the actual tag point is displayed 
in the status bar. 
 

  
 
Home (Pos 1) selects the first tag point, end 
(Ende) selects the last tag point of a path. 
 
ESC resets the tag position 

 
EASY-ROB™ status bar 
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EASY-ROB™ Operation References 

General Functions 

Positioning the floor 

 

 
 
With this version of EASY-ROB you are able to change position and orientation of the floor in EASY-ROB. 
 
Call the Fame Dialog with the menu „View | Floor | Floor Position“. 
 

 

See as well the chapter  „Frame Dialog“ 

 
  

Move floor  
in x, y oder z- direction 

Turn floor  
around x, y oder z- direction 
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EASY-ROB™ Operation References  

General Functions 

TCP Trace 

 

 
For the TCP Trace you are able now to change the length, the thickness and the reference. 
 
Use the menu „View | TCP Trace  
 

 

 
 

 
Switch TCP Trace ON or OFF 

 

 
 

 
Settings for the type 
Line   Trace as a line  
Point   Trace as a dotted line 
Line + Z  line with approach-axis in Z 
Z App.   approach-axis in Z 
X App.   approach-axis in X 
Y App.   approach-axis in Y 

 

 
 

 
 

 
Change the color of the TCP Trace 

switch TCP Trace  on / off 

change type  

change color 

change length & thickness 

change reference 
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General Functions 
 

 

 
 
 

 
 

 
 
 
 
 
Change  

- thickness for the TCP Trace 
 
 

 

 
 

 
 

- approach length for the TCP Trace 
 
 

 

 
 
 

 
 

- point size for the TCP Trace 
 
 

 

 
 
 

 
 

 
 
Select the reference for the TCP Trace 
 
Options: 

- referred to world 
- referred to robotbase 
- referred to a joint of the robot 
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EASY-ROB™ Operation References 

General Functions 

Collision check in EASY-ROBTM  

 

 
The Collision check in EASY-ROBTM enables you to check all objects in the workcell for collision. 
 
You can check object vs. object or group vs. group.  
Example: You know for sure that the robot can not reach the fence with axis 1 to 4, because of the axis 
limits. So you just have to check only axis 5 and 6 vs. the surrounding fence. 
The reduction of the number of objects in the collisions queue will reduce the calculation time for the 
collision check. 
 
The internal mechanism of the collision check works in a hierarchy: first the system will check for bounding 
box; after that it will for concave or convex. 
 
The system will check for collision while running a program and while manual movement of the robot by 
moving the TCP or the joints. 
 
In case of collision, the colliding parts will change their color to red and - depending on the settings – the 
simulation will stop. 
 
On top of the regular collision check, EASY-ROBTM provides a function for a near-miss-collision-check. So 
you can set a minimum distance (safety area) and every time the robot moves below the value, you will see 
a warning for collision, although there is no real collision. 
(Note: the near-miss-check only works with convex bodies) 
 
 
All collision related functions can be set manual (by buttons) or automatically by an ERCL command in a 
program.  
(see document  „EASY-ROB_ERPL_ENG.pdf“, a documentation of all ERCL-commands) 
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Collision check in EASY-ROBTM 
 

 
The mechanism for collisions detection in EASY-ROBTM works on 3 levels: 
 

1. global ON / OFF, to switch collisions detection on or off 
  

 
2. predefined collision queues  

The following listed collision queues are predefined and can be switched on or off by the user:  
 
BODY_ROBOT  – collision check between Body and Robot 
BODY_TOOL   – collision check between Body and  Tool 
ROBOT_TOOL  – collision check between Robot and Tool 
GRABBODY_ROBOT  – collision check between „grabbed“ Body and Robot 
GRABBODY_ BODY  – collision check between „grabbed“ and „not-grabbed“  Body  
ROBOT_ROBOT  – collision check between all geometries in the same Robot group  
BODY_BODY   – collision check between all geometries in the same Body group  
 

 
3. collision attributes on the object-/geometry level 

Each object does have (beside other attributes) an attribute with the name „Check Collision“ 
With this attribute the user can define if and how he wants to check the object for collision. 
The parameters are: 
 
OFF  - no collision detection for the object 
BBOX  - check with „bounding boxes“ 
CONVEX - check convex 
CONCAVE - check concave 
 
The default setting is the check for „CONCAVE“  
 
Note: If one object is set to BBOX or CONVEX and the other object is set to CONCAVE,  the 
collision check will be done CONCAVE. 

 
 
 
NOTE: 
The correct setting of the switches on all three levels is very important. A few examples: 
 
a)  
collsion check “ON”, collision queue Body-Robot „ON“, attribute „Check Collision“ is „OFF 
-> even when a collision exist – it won’t be detected or shown, because the attribute for the geometry is set 
to „OFF“ 
 
 b)  
collsion check “ON”, collision queue Body-Robot is „OFF“, attribute „Check Collision“ is „CONCAVE“ 
-> even when a collision exist – it won’t be detected or shown, because the collision queue is set to „OFF“ 
 
 

mailto:info@easy-rob.com
http://www.easy-rob.com/


 

Subject to change or improve without prior notice 52/108 

  
EASY-ROB Software GmbH  Hauptstr.42  65719 Hofheim am Taunus  Germany  Phone: +49 6192 921 70-77  FAX: +49 6192 921 70-66  info.er@easy-rob.com  www.easy-rob.com 

Collision check in EASY-ROBTM 
 

 
Overview of the dependence of the 3 levels of the collision detection: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

COLLISION 

ON 

OFF 

COLLISION QUEUE 
 
BODY_ROBOT 
BODY_TOOL 
ROBOT_TOOL 
GRABBODY_ROBOT 
GRABBODY_ BODY 
ROBOT_ROBOT 
BODY_BODY 
ALL 

ON 

OFF 

COLLISION BODY 
oder 
COLLISION BODY_GRP 

CONCAVE 
oder 
CONVEX 
oder 
BBOX 

OFF 

Check and Display 
COLLISION 

NO Check and NO 
Display COLLISION 
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Collision check in EASY-ROBTM 
 

 
 
 
 

switch collision detection ON or OFF 

 
 

 
 

Opens the dialog to switch collision queues ON or OFF 

 

 
 

 

 

 

 

dialog to switch collision queues ON or OFF 

 

double click on the item will toggle between  

ON and OFF 

 

 
 
 
 

 
 

 

 

Attribute „Check Collision“  set to „Concave“ 

 

 

 

 

 

 

 

 

double click on the attribute will open a dialog 

to change the setting 
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EASY-ROB™ 
 

Operation References 

General Functions 

How to export a workcell  

 

 
Sending an EASY-ROBTM workcell by email for instance to a colleague or a customer (which is not working 
on the same PC or in the same network) will always bring up the following question: 
“Are all required data included into the shipment ?!” 
 
If it is a workcell with many devices consisting of many parts and a program on top, it can be a time-
consuming task to collect each single item. 
 
 
The EASY-ROB™ function “Export Workcell” supports the user to collect all related items of the workcell. 
It will copy the current workcell and all related files such as IGP-files and programs to a new folder. 
 
 
 

 
2. 
Load the workcell  
 
Spotweld_Demo.cel 
 
with the button Load from Library 
from the directory:   
 
../EASY-ROB / ApplicationLib / 
Spotwelding 
 

 
 

or 
shortcut 
„Ctrl+Shift+O“ 

 
 

 
2. 
Start the export by menu  
File | Save | Cell File Export 
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How to export a workcell 
 

 
3. 
Reset the position and overwrite the 
existing workcell 
 

 

 
4. 
Now select or create the destination 
folder (where to store the data) 
 
The default path will be the 
destination folder  of the EASY-
ROBTM installation: 
C:\Program Files\EASY-ROB 
 
in a subdirectory called  
“\EASY-ROB\Proj-
Export\TARGET_DIR” 
 
 
Confirm the default path with “Save” 
 

 
 

 
 
 
 
 

 
5.  
Confirm the next question with “Yes” 
 
to run the batch file and to export the 
data to the selected directory. 
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How to export a workcell 
 

 
7. 
After finishing the batch run, press 
any key to close the command shell. 
 
 

 

 
 
 

 
8. 
All workcell related data  

- workcell-file 
- program 
- mimic 
- parts 

are now copied to the selected 
directory. 
 
C:\Program Files\EASY-ROB\EASY-
ROB\Proj-Export\proj 
 
The parts of all devices are placed in 
the igp folder. 
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EASY-ROB™ Operation References 

Dialogs & Windows 

Device Manager 

 

 
The Device Manager provides the functionality “to look into a workcell or robot” without loading the file. 
Because of the “visible information” through the Device Manager, the user is able to identify immediately if it 
is the desired workcell or robot. 
Beside a screenshot of the workcell or robot additional information as text can be stored. 
By using the path history and the list of preferred paths it is possible to navigate through the file tree with 
just a few mouse clicks. 
On top it is possible to send certain data from the Device Manager to the Project Manager. (see chapter 
„Project Manager“ in this document)  
 

 
1. 
Open the Deveice Manager by the button „Start 
Device Manager” or Ctrl + Shift + O 
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Visual File Interface 
 

 

 
 

 
Path history: 
 
Every time when loading a workcell or a robot into 
EASY-ROB™, the system will store the origin path 
where the data coming from into the path history. 
The maximum number of listed paths is 12.  
Identical path names will be listed only one time. 
 
 
The file „er_LoadFromLibPb.ini“, which contains 
the path history, will be administrated 
automatically. Do not edit is manually. 

 

 
 

 
Preferred paths: 
 
Unlike the automatically created path history, won’t 
the list of preferred path change when loading from 
library. That enables the user to have always a quick 
access to the 12 most important paths. 
 
The list of preferred paths has to be created by the 
user and will be stored in the file 
„er_LoadFromLibPb_prefered.ini“ in the EASY-
ROB™-target directory and be edit through: 
Menu/File/ Edit/EASY-ROB-SystemFiles. 

 

 
 

 
Pre-selection of the displayed file type in 
the list 

 
 
 
 

 
Send data of the workcell to the Project 
Manager 

 
 
 

 

 
Function to create a screenshot 

 
 
 
 

 
Load the selected file 

 
 
 

 

 
Cancel the function 
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EASY-ROB™ Operation References 

Dialogs & Windows 

Capture Image 

 

 
The EASY-ROB™ Capture Image Dialog enables the user to create screenshots in BMP- or JPEG format. 
 

 
1. 
Load at first the robot or the workcell by the 
Library Dialog into the EASY-ROB™ 
 

 

 
2. 
After loading the cell or the robot call the „Capture 
Image“ – function from the EASY-ROB™ Library 
Dialog 
 
 

Tip:  Select first the file you 
want to capture (in the 
example„multi_paint_01.
cel“), before you activate 
„Capture Image“. By 
doing this the system will 
know the file name and 
can take it for the picture. 

 

 

 
 

 
3. 
Position the „Capture Image Window“.  
 
Depending on the pre-selected file format the 
Capture Image will create a BMP- or JPEG file by 
hitting the „Shoot”-button. 
 
 
The picture will be stored in the same directory 
like the workcell or the robot. 
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EASY-ROB™ Operation References 

Dialogs & Windows 

Navigator Window 

 
 

The Navigator Window is used for selecting geometries and tag points as well as measuring distances in the 
3D scene. The Cruise Mode defines the point that the 3D scene will rotate around. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Selection for measurement 

Select Body/Tag 
Select a geometry or a tag point by left clicking it. This object is 
current. 

Point Measure 
Select a point on a geometry by left clicking it to show its 
coordinates. 

Distance Measure 
Used for distance measurement between points, faces and tag 
points. 

 

Selecting the rotation center point 

 

By selecting Modify World View 

the 3D scene you can move the scene, zoom in and 

out or rotate around a point. 

The following reference systems are available as rotation center. 

• World Coorsys: (default) 
The world coordinate system is the rotation center. 

• Robot Base: 
The robot base is the rotation centre. 

• Robot TCP: 
The robots TCP is the rotation centre. 

• current Body: 
The coordinate system of the actual geometry or tag point  will 
be used as rotation center. 

• picket Point: 
The selected point on a geometry is the rotation center. 

selection for measurement 

the center point for rotation of 
the 3D scene 

camera settings 
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Navigator Window 
 

You can switch between the actual Mouse Mode and the last recent Mouse Mode by pressing Space. 
 

 
 
 

Camera settings 
 
 
 
 
 

You can achieve optimal view points using the camera. For 
optimal results it’s attached to a geometry. If the mouse mode 
Modify World View is active you can switch between camera- and 
world-view by pressing TAB 
The line of sight is always in negative Z-direction according to the 
OpenGL™ definition. 

 

 
 Changes the focus by 10 mm per click. 

Double click Focus length in the property list to set up an exact 
focus value. 

 The Z offset value moves the lens in Z-direction (line of sight)  
The Z-offset changes by 10 mm per click. 
Double click Z offset in the property list to set up an exact offset 
value. 

 
 

Property list 

 

Exact values can be entered by double clicking an entry in the 
property list. 
 
 
 

Selecting the geometry or the 
tag point the camera shall be 
attached to. 

 
 
 
 

Offset adjustment and -rotation with respect to the camera 
reference system. 

  

apply changes 

switching camera on 
and off exit dialog 

reset camera settings 

choose geometry 

property list 

set up focus and 
offset 
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EASY-ROB™ Operation References 

Dialogs & Windows 

Frame Dialog 

 

 
The frame dialog is used for entering cartesian coordinates. To redefine the 3D geometries, the base or the 
TCP of the robot for example, the values for the actual X-, Y- and Z-values with their orientation are shown in 
the Frame Dialog and can be edited. The new coordinates are instantly visualized without closing the dialog 
which makes fast verification of the values possible. Furthermore the actual positions can be stored for other 
usage. Even multiplying and inverting homogenous matrices (frames) is possible. 
 
The Frame Dialog is one of the central user dialogs in EASY-ROB™ and is used very often when working 
with the program. 
 

 
 

 
Closes the Frame Dialog and accepts the entered coordinates. 

 
Short help for the Frame Dialog. 

 
Updates the 3D scene according the new coordinates. “GraficUpdate“  is 
useful for a fast verification of the coordinates without leaving the dialog. 

 
Reset to the original coordinates before the Frame Dialog was opened. 

 
Copies the coordinates to the frame list (clipboard).  
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Copy coordinates from the clipboard. 

 
Sets coordinates and orientation to null and identity. 

 
Closes the Frame Dialog and discards all changes made. 

 The information line shows to which object the coordinates apply to. 

 

 
 

Coordinate fields for position and orientation. 
 
Formulas are also allowed for example „200.0+57.3*pi/180“, „0.2*m2mm“, 
„100*sin(45*RAD)“, „a1=5;8*a1“ or „3*a1“ 
The formula will be calculated when the cursor leaves the field so simply 
select another one. 
 
Dist. calculates the amount of x-, y- and z-value. 

 

This is a delta value that a coordinate value should be incremented or 
decremented by. 

 

The position coordinate x, y, or z will be incremented / decremented by the 
value of "dist" with the following buttons: 
 

- -dx  or  +dx  for x direction 
- -dy  or  +dy  for y direction 
- -dz  or  +dz  for z direction 

 
This change is absolute or relative. The 3D scene is automatically redrawn 
for verification. 

 

The orientation coordinate Rx, Ry, or Rz will be incremented / decremented 
by the value of "dR" with the following buttons: 
 

- -Rx  or  +Rx  for x direction 
- -Ry  or  +Ry  for y direction 
- -Rz  or  +Rz  for z direction 

 
This change is absolute or relative. The 3D scene is automatically redrawn 
for verification. 

 
Changes are absolute in the reference system Tnew = dT(dist,dR) * Told 

 
Changes are relative Tnew = Told * dT(dist,dR) 
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Frame Dialog 
 

 

 
Setting the orientation rule and  
conversion of the actual orientation 
into other wrist configurations. 
 
e.g.. • ABB S4 Quaternions 
 • KUKA KRC1 RzRyRx 
 • Stäubli RzRyRz 
 • Fanuc Karel RJ Roll Pitch Yaw 
 • Tricept TR8x5 Rz(C)Rx(A) 
 
 
 

 
 

 
Frame list for matrix calculations. 
 
For calculations with the actual coordinates (named T1) they must be copied 
into the clipboard first (there named T2). 
 
You can now invert the homogenous matrix T2 or make other calculations 
with another actual coordinate T1. 
 
The result in T2 can be copied back to T1 and there be used for further 
processing. 
 
Hint: 
A double click in the frame list for example on „1 - X: 1000.000“ transfers the 
value into the X-coordinate. The same can be done with the Y- and Z-
coordinates and the orientation coordinates. 
 

 
Swaps matrix T1 and matrix T2. 

 

Resets the matrix T2 to its original values. 

 
Matrix multiplication T2 = T2 * T1 

 
Matrix multiplication T2 = T1 * T2 

 
Matrix multiplication T2 = T2

-1 * T1  

 
Matrix multiplication T2 = T1

-1 * T2  

 
Matrix inversion T2 = T2

-1  
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EASY-ROB™ Operation References 

Dialogs & Windows 

3D CAD Window 

 

 
The 3D-CAD window is used for importing and positioning 3D geometries and for setting colors and other 
attributes. 
 
By a single click on the button              the 3D-CAD window will show up. 
 
 

 
 
 
 
 

body list 

 
The body list shows all geometries of the actual group by name. 
 
Clicking twice on a list element will show up detailed information 
about the geometry. 
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3D CAD Window 
 

 
 

group selection 

 
EASY-ROB™ provides three groups for the creation of bodies. 
They can be separately stored and edited. 
 
File → Save → Robotfile 
 Toolfile 
 Bodyfile 

 

 
 

create / import a body 
 
 
 
 
 
 
 
 
 
 
 

 

 

Bodies can be created or imported. 
 

 
geometry properties 

 
 

 

The properties of the actual geometry can be changed by a 
double click. 
  

#[number]  name 

[attached to axis]   
( 0 = robot base, 1-12 = active axis 1, otherwise = passive axis) 

scale value of the geometry 

type and state 

GB color value 

 

offset position and -orientation  

 

product of reference position and offset position 
 

reference position and reference orientation 

world position and -orientation 

 

save / reset changes 
 

 

If the position of the actual geometry has been changed then this 
can be stored as home position by clicking Save.  

Reset discards all changes. 
 

Import from  
EASY-ROB™ 

3D-CAD Library 

Import existing 
3D-CAD Files. 
VRML I + II (97) Data 
have to be in IGP® format 

create primitive 
bodies 
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3D CAD Window 
 

 
Delete the actual geometry from the 3D-scene 

 

 
 

Merge the selected body ( see chapter „Import of VRML“ in this 
document) 

 

 
Move the part up or down in the listing 

 
position / orientation of 

the geometry 
 
 

 
 
 
 
 
 
 
 

 

The position and orientation of the actual geometry can be 
changed in the frame dialog. 
 

 
Offset position Toff 

 
Reference position  TRef 

  
Product of reference position and offset position  TRef * Toff 

 
Set position with respect to the world origin 

click the check box „Measure“ to open 
the Navigator window 
 

 
Hint: 

 

Values measured with the Navigator window 
can be used for further calculations. For 
example the value 877.337 is stored in the 
system variable $dx so you don't have to 
transcribe or remember the value. 
 

Rotates and 
translates the body in 
reference to its own 
coordinate system. 
 
After every rotation 
about x,y or z the 
coordinate system 
has a new orientation. 

Rotates and 
translates the 
body in reference 
to the world 
coordinate 
system 
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3D CAD Window 
 

 
coordinate systems 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  

e.g. robot 
 axis 
 

product of 
reference- and 
offset position 

reference  
position 

offset position 

world position 

geometry 

world coordinate system (0,0,0) 
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EASY-ROB™ Operation References 

Dialogs & Windows 

Kinematics Window 

 

 
The Kinematics Window enables the user to handle robots in the workcell or respectively modify the properties 
of the robots. 
 
To activate the Kinematics Window just use the menu Robotics / Kinematics Window or use the shortcut 
„Ctrl+K“ 
 

 
 
 

 

 
 

 
The list contains information about the current state of the selected robot 
e.g.: 

- name 
- attach to – Status 
- position / orientation of the base, the TCP and the tool 

 
Tip: 
To change the values just double click onto a value. 
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Kinematics Window 
 

 

 
Select a robot 
 
With the buttons       and         you can switch between the robots  

 
 

                   opens the following dialog with a list of all loaded robots: 
 

 
 

 

 
Re-Attach of a robot 
 
Opens the following dialog: 
 

 
 
to re-attach the current robot to another  „link“  
 

 

 
Select a robot 
 
Function to select a robot by mouse click in the workcell 
 

 

 
Load new robot 
 

 

 
Save current selected robot 
 

 

 

 
Snap robot to the chosen Polygon or Vertex 
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Kinematics Window 
 

 

 
Remove the robot from work cell 
 

 

 
Attributes of the robot 
 
Opens the following dialog to modify the listed properties. 
 

 
 

 

 
Kinematics of the robot 
 
Opens the following dialog:  

 

 
 
 

to modify kinematics properties . 
 

 

 
Creates a new robot 
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Kinematics Window 
 

 

 
Save and reset Start Conditions 
 

 
 

 

 
Refreshes of the data in the status list 
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EASY-ROB™ Operation References 

Dialogs & Windows 

Jog Window 

 

 
The JogWindow is used to jog or manipulate the robot with a 3 button mouse in individual axes or the TCP in 
reference to tool- or world coordinates in a fast and comfort way. 
In addition the travel ranges and collision monitoring can be activated. 

 

 

 

The list contains a few ERPL- and ERCL example commands, 
 
like movement commands LIN, LIN_REL, CIRC ... etc. 
 ERCL - commands Color, Track, Tag … etc. 
 
More commands can be added to the list. 

 

 
By input or double click on a command in the list the command is transferred 
to the command line. 
 

With         the command is inserted at the marked position. 
 

With         the command is removed from the list. 
 

With          the command in the command line is executed. 
 

 

 

The axes 1-3 are moved with a 3 button mouse by pressing a button and 
moving the mouse in the 3D-scene.. 
 

Left mouse button  axis 1 
Middle mouse button axis 2 
Right mouse button axis 3 
 

With the TAB key the axes 4-6, 7-9 and 10-12 are selected. 
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Jog Window 
 

 

 
 

 
Assigning the axis to LMB  

 

 

 
Jog the axis 
 
 

 

 

 

TCP-movement related to tool coorsys → TCP Tool Mouse-Mode. 
 
This button is equivalent to the Short-Key 
 

 

 
 

 

TCP-movement related to world coorsys → TCP World Mouse-Mode. 
 
This button is equivalent to the Short-Key 
 

 

 

 
Switch to rotational TCP-movement 

 

 
 

 
Selection of the robot 

 

 

 
Switch on the Cruise Mode 
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EASY-ROB™ Operation References 

Dialogs & Windows 

Tag Window 

 

 
In the tag window paths are being created and edited independent of each other and placed in the space. A 
path consists of multiple tag points and can be attached to a geometry, a robot base or tip. If the geometry or 
the robot position changes, the attached path is moved simultaneously. You can select single tag points  or a 
group of tags. As usual you can use the short keys „Ctrl + A“, „Ctrl + C“, und „Ctrl+ V”. 
 
 
The Tag Window can be accessed by clicking SEL TAG. 
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Tag Window 
 

TCP Jog  The robot jumps to the selected tag point. 

Show cTag 

The tag points are connected with color-marked arrows. 
 

• violet:  from the reference system to the Wobj-frame 
• green:   from the Wobj-frame to the 1st tag 
• yellow:   from the 1st tag to the following (2nd) Tag etc. 
• red:   from the last but one tag to the last tag 

Measure Opens the Navigator dialog → „Pick a Tag“ mode is active 

Tag list 
In this list all tags of the actual path are shown. 
With a double click on a tag the robot will move toward it. 

 
 
                       Create tag points 
                       attached to geometry. 

Tag points attached to geometry can be created. 
 

Left mouse button: select position on the geometry 
Middle mouse button:  create new tag point on the TCP 
Right mouse button:  place selected tag point 
 

The position on the geometry is shown by a pink arrow. 

 Moves the selected tag point in the list up and down one position. 

 Moves the robot tag to tag along the path. The motion mode is 
specified by the tag point. 

 Move towards selected tag point, →  double click on a tag in the 
tag list 

 Selection of next or previous tag point. 

 
Motion type of 
the robot 

 

Clicking the button                         makes the robot move toward 
 

the selected tag. The motion mode can be specified as follows. 
 

Motype Attributes as described in the tag properties 
PTP PTP mode (Point to Point, synchro PTP) 
LIN LIN  mode (linear) 

 
Tag point properties 
 

 

A property can be edited in a new dialog by double clicking on it. 
 
 

#[tag number] [world object name] [path] : [prefix] _ [tag name] 

The Body the path is attached to 

Position of the Workobject-frame 

Orientation of the Workobject-frame 

Position of the tag in respect to the Workobject-frame 

Orientation of the tag in respect to the Workobject-frame 

Motion mode of the tag 

Velocity in tag point „0“ → undefined 

Color of the tag 

Render type 

Size of the shown tag coorsys 
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Tag Window 
 

 

 

 
The position and orientation of the marked tag or of the 
Workobject-frame can be entered or edited. 
Corresponds with a double click in the tag point-property list 
„TagPos.“ 

    

Creating, editing, removing and selecting paths. 
„ReAttach“ →  Attach path to geometry or robot. 

 # [path number/path count]  [path name] : [Workobject name] 

 
Select a path 

 

 
Attach the path to a 
geometry or 
a robot 
 
If the geometry is moved 
the robot moves 
simultaneously. 

 

 
Change the name of the path or workobject 

    
Clone Path, new path and delete the current path 

 A new tag is created at the current TCP position. 
Corresponds with a middle mouse button click in the „Pick a Tag“ 
mode 

 Current Tag will be moved to TCP of cRobot 

  Change the [prefix] _ [tag name] 

  
Clone or delete current tag 

  

  

Open Frame-Dialog to edit  
tag- oder workobject-positions 
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Tag Window 
 

 
Activates MouseMode „sel Tag“   

The  cursor appears 

   Pick a Tag in 3D-Scene → cTag 

  

 
Pick a polygon or a Vertice with  LMB 
Middle mouse button: create new tag point on the TCP 
Right mouse button: place selected tag point to position 
 

 →

 

 cTag will be snapped to Polygon or Vertex 

 Referesh of Tag-Window data  
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Tag Window 
 

Procedure for creating a path and attaching it to a geometry 

 

Create a geometry 
 

3D-Cad Window  

Select a path If necessary change the name of the path and the Workobject-frame. 

Create a tag on the 
TCP 

 

The first tag will be placed at the actual TCP-position. 

Re Attach 

Selection 5 – Pick Body  
Click the geometry, it will be framed with a bounding-box. 
All subsequent created tags of the path are attached to the 
geometry and simultaneously move with it. 
The geometry can part of the robot/machine, the tool or the work 
piece. 

Pick a Tag 

 

Additional tag points can be created by clicking on the geometry. 
 

Left mouse button: select position on the geometry 
Middle mouse button:  create new tag point on the TCP 
Right mouse button:  place selected tag point 
 
With a right mouse click the current selected tag point will be 
placed on the position, which was selected before with the left 
mouse button (Pick & Click). The middle mouse button is merely 
needed for adding a further tag point on the path. 
If the center of a polygon was selected, then its normal vector will 
be taken over as Z-component of the tag point. The actual TCP-
position will be used for calculating the X- and Y-components of 
the tag point. 
If a point of the geometry was selected, then the current TCP 
orientation will be used for the orientation of the tag point. 
Hint: Move the robot to the first tag point and adjust it. 
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Tag Window 
 

Coordinate- and reference systems of a path 

 

Ref. Pos. 

Reference position    • world coordinate origin 
 • robot base 
 • robot tip (muff) 
 • robot TCP 
 • body 
 
The path reference position is always described in world coordinates and 
depends on which object the path is attached to. The values for the reference 
position change when for example the geometry or the robot base is moved. 

 

Wobj. Pos. 

Workobject-position „Wobj.Pos.“ 
 

The position of the Workobject is described with respect to the reference 
position. 
 
With Show cTag activated the link between the reference position and the 
Wobj.Pos. will be shown in violet. 

 

Tag Pos. 

Tag positions 
 

All tag positions of a path are described with respect to the position of the 
Workobject. 
 
With Show cTag activated the tag points will be connected with yellow arrows. 
The arrow to the 1st tag is green, the one to the last tag is red. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Ref. Pos. 

PATH 

world coordinate system (0,0,0) 

Wobj. Pos. 
tag pos. 

tag point 
"T_1" 

tag point 
"T_2" 

tag point 
"T_3" 

mailto:info@easy-rob.com
http://www.easy-rob.com/


 

Subject to change or improve without prior notice 81/108 

  
EASY-ROB Software GmbH  Hauptstr.42  65719 Hofheim am Taunus  Germany  Phone: +49 6192 921 70-77  FAX: +49 6192 921 70-66  info.er@easy-rob.com  www.easy-rob.com 
 

EASY-ROB™ Operation References 

Dialogs & Windows 

Teach Window 
 

 

 
Using the Teach Window you can easily create accurate simulation programs in ERPL - the EASY-ROB™ 
Program Language and ERCL the EASY-ROB™ Command Language. The desired motion- and simulation 
commands are automatically inserted and can be executed line by line for testing. After storing the program 
file, the whole program can be simulated. 
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Teach Window 
 

Editing the actual program file 

 Discards program changes by simply reloading the file. 

 
Loads the actual program file in the editor specified in the configuration file 
„config.dat“. 

 Start with a new, empty program. 

 Stores the current content of the window in a program file. 

 Overwrite the current file with the actual content of the program window. 

 Load a program file. 

 

 Unload the current program 

 Online help for the Teach Window. 

Edit line for command execution 

 
Edit line with the ERCL command „ERC TRACK ON“ for switching on the TCP 
trace. 

 
Writes the entered command at the actual position in the source code window. 
Overwrites an existing code line at the position. 

 Executes the command in the edit line as single step. 

Creating / editing a command line 

 
Shows the actual line number in the source code window. By clicking the button 
you can enter a new line number. 

 A star after the actual line number says that its contents where modified. 

 
Inserts the code in the edit line at the marked position in the source code window. 
The commands below will be moved down. 

 Cuts the selected program code. The code below will be moved up. 

 Reinserts the previously cutted code and moves down the rest of the code. 

 Copies the currently selected code to the clipboard. 

 
Inserts the code from the clipboard at the marked line. The code below will be 
moved down. 

 Copies the selected line to the edit line for editing or execution. 

 Search for a text the next position of it 
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Teach Window 
 

Creating motion commands with respect to the actual TCP position 

 Moves the robot to its home position. 

 Synchro-PTP motion command axis specific  

 Synchro-PTP motion command for the actual TCP position. 

 LIN motion command for the actual TCP position. 

 
VIA motion command for the actual TCP position. 
This means the point needed for the circle interpolation. 

 CIRC motion command for the actual TCP position. 

Creating motion commands on tag points 

 

Select a tag point by clicking it with the left mouse button in the 3D scene. The 
selected tag is shown with a pink arrow. 
Name and path of the actual tag are displayed in the main windows status bar. 

 

Selection of paths and tags. 
The first two <> arrows cycle through the paths, 
the second <> arrows cycle through the tags. 
Name and path of the actual tag are displayed in the main windows status bar. 

 
Moves the robot to the actual tag using the motion type of that tag (see Tag 
Window). 

 Selects motion type synchro-PTP for the actual tag. 

 Selects motion type LIN for the actual tag. 

 The actual tag will be stored as an intermediate point for a CIRC motion. 

 
Selects motion type CIRC for the actual tag. The robot will move through the VIA-
point. 

Programming further motion commands 

 

 
 
Opens a dialog with further motion commands. 
 
e.g. PTP_Rel, LIN_Rel.... etc. 
 
Explanations for these commands can be found 
in the online help in: Robot Motion Command 
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Teach Window 
 

 

 
 
 
Opens a dialog with further control commands. 
 
e.g. Speed_CP, ACCEL_CP.... etc. 
 
Explanations for these commands can be found 
in the online help in: Robot Control Command 

 

 
 
Opens a dialog with further EASY-ROB™ commands. 
 
e.g. ERC COLLISION ON, ERC TRACK OFF... etc. 
 
 
Explanations for these commands can be found 
in the online help in:  
ERCL  -  EASY-ROB™  Command  Language 

 
Run single program step 

 Help to Teach Windo 

 Opens program window 
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Teach Window 
 

 
Example: „KR30-2-TAGS.PRG“ 
in file „..\ EASY-ROB \ Tutorial \ Functional \ KR30-2-
Tags.cel“ 
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EASY-ROB™ Operation References 

Dialogs & Windows 

CAD-Import Window 
 

 
 

 
EASY-ROB™ uses the 3D_Evolution® API of CT Core Technology GmbH to import CAD data. The CT 
Kernel_IO was especially designed for CAD data import and allows importing and optimizing CAD data 
formats generated by different CAD-Systems. 
 
Please read first the chapter „CAD Import (CT Kernel_IO) into the Installation-Guidelines ! 
 
 
After converting CAD geometry it will be loaded automatically into the CAD Preview. Depending on the 
requirements the tessellation of the workpiece can be manipulated for e.g.data reduction. 
„Restore“ will convert the geometry again and will load it for the examination automatically into the CAD 
Preview.  
For further optimization functions like „merge“, „healing“ and „sewing“ are available. 
 
All required functions are provided in the CAD-Import Window. 
 
Open the CAD-Import Window through the menu „3D-CAD | Open CAD-Import Window“. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

File | Load Load and convert data into the workcell 

File | Save Saving the CAD data and the CAD-Import message 

File | Unload Unload the CAD data  

Menu 

Information 

Data handling 

Tesselation / 
Display 

Additional functions 

Messages 
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CAD-Import Window 
 

3D-CAD 
Functions to scale, to set the position, to show edges, to merge and to show the 
object information 

Settings Show, change and reset the tessellation 

FlexLM 
Start, stop the FlexLM for the CAD-Import 
show the logfile and the license 

 Load and convert CAD Data and load it automatically into the CAD Preview 

 
Convert again a loaded CAD geometry after changing tessellation parameter and 
load it automatically into the CAD Preview  

 Reload the converted IGP file 

 
Show the object information like file name and path, number of objects, lines, 
vertices, polygons, scaling and position 

 
Merge will reduce the number of objects and will increase the number of polygons 
per object 

 
Change the Tessellation of the geometry (Solids) 

 

 
 

Change the size of the polygons and the angle between the polygons (Solids) 

 „Heal“ the object. Open geometries will be closed. 

 
“Sew” edges which are within a tolerance  

 
Original colors will be overwritten and it possible to change them afterwards in 
EASY-ROB. 

 
Consideration of the assembly structure (no function yet) 

 
Warning level; “verbose“, „normal“ and „silent“  

 Close the CAD-Import Window 
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EASY-ROB™ Operation References 

Mini Tutorial 

Creating Tags on 3D geometries 

 

 
The following text will describe step by step how to create paths and tags on a face or at a vertex of a 3D 
geometry. Paths and tag points are attached to the geometry even if it changes its position. 
 
The file CreateTags.cel will be used as an example. 
 
Note: 
Please read as well the operation reference for the Tag Window and the 3D-Cad Window which will be used 
here. 

 
Step 1: 
 
 
Load the robot from the TrainLib: 
 
File / Load / Robot file 
 
 
The ER431 will be used for this 
example. 
 
../ EASY-ROB / TrainLib / ER431.rob 

 

 
 

 
Step 2: 
 
Load the tool from the TrainLib: 
 
File / Load / Tool file 
 
the example is:  tool.tol 
 
 
../ EASY-ROB / TrainLib / tool.rob 

 
 

 
 

Tool 
Daten 

TCP 
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Creating tags on 3D geometries 
 

Step 3: 
 
Create a cylinder (3D geometry) and 
position it. 
 
metrics: 
Radius 200 mm 
High1 500 mm 
Radius Top 200 mm 
High2 500 mm 
 
 
offset position: 
X 2000 mm 
Y       0 mm 
Z     50 mm 
Rx       0° 
Ry    -10° 
Rz       0° 

 

 

Step 4: 
 
Name the path and the work object: 
 
e.g. path: BODY 
       wobj: CYLINDER 

 
 

 
Step 5: 
 
The new path should be assigned 
(attached) to the cylinder and move 
with its position. 
 
Choose  ReAttach 
and  5 - Pick Body 
and then click on the cylinder. 
 
The next question for “Keep World 
Position” answer with “No”. 
 
The path with its tag points is now 
attached to the cylinder. 
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Creating tags on 3D geometries 
 

 
Step 6: 
 
The cylinders coordinate system has 
another orientation than the coordinate 
system of the TCP. 
 
To place the first tag point directly on 
the surface of cylinder cap  
 

- activate  Pick a Tag  and left - 
click the designated face 

- create a new tag on the robots 
TCP by clicking once with the 
middle mouse button 

- assign the tag on the TCP the 
correct position on the cylinder by  
once clicking it with the right 
mouse button. 

 
Double clicking the currently created 
tag point in the Tag Window causes the 
robot to move to this position. 

 
 
 
 

left mouse button: select a position on the geometry 
middle mouse button: create a new tag point on the TCP 
right mouse button: place the tag point at the position of 
  the geometry. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 7: 
 
More tag points shall be created. 
 
Open the Navigator Window : 

 
 

 
Step 8: 
 
Selecting points on a geometry 
 
 
Activate Point Measure and 
Vertices in the Navigator 
Window. 
 
 
If Vertices  is selected then the vertices 
of all 3D geometries are shown with 
yellow points and can be selected 
using the left mouse button. 
 
 
 

 
 

Aligning the tags to surface normal 

  Cylinder with Vertices 
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Creating tags on 3D geometries 
 

 
Step 9: 
 
To create more tag points with the 
same orientation as the first tag point 
the robot must first be moved to it. 
 
Now select a vertex on the cylinder 
with the left mouse button. 
 
Create a new tag point on the robots 
TCP with the middle mouse button. 
 
Assign the position on the cylinder to 
the new tag on the robots TCP by 
clicking once with the right mouse 
button.  
 
The last operation will cause the tag to 
change its position from the robots 
TCP to the selected vertex on the 
cylinder. 
 

 
 

left mouse button: select a position on the geometry 
middle mouse button: create a new tag point on the TCP 
right mouse button: place the tag point at the position of 
  the geometry. 
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EASY-ROB™ Operation References 

Mini Tutorial 

Multi-KIN 

 
The option “EASY-ROB™ Multi-KIN“ enables you to load and run any number of robots (*.rob-files) with an 
inverse kinematics solution and more than three axis/joints into the work cell. Robots with up to three 
axis/joints such as conveyors, positioner or xyz gantries, don’t need Option “Multi-KIN“ and can be loaded 
as much as required. 
 
With Option “Multi-KIN“, all robots / kinematics in a simulation are able to move to cartesian positions. That 
means that you can simulate both: processes between robots and processes between robots and e.g. 
conveyor in one simulation. 
 
There is only one program in the work cell which contains all commands for all robots. 
 
As an example see the work cell „tutorial_multi_kin.cel“ from TrainLib-directory. 
 
Remark: Please also read the part “Teach Window“ in the general Operation Reference. 
 
 

 
        Example work cell: „tutorial_multi_kin.cel“ 
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Multi-KIN 
 

Working with Multi-KIN (Workcell „example_multi_kin.cel“) 

 Please load the workcell „tutorial_multi_kin.cel“ from TrainLib 

open Kinematics 
Window  

 
with the menu Robotics / Kinematics Window or the keys „Ctrl+K“ 
 

select Robot 
 

activate with arrow keys or „sel Robot“ the Robot „KR125-2“  

open Teach Window  
 

new program   

activate line 
 

set active line to 10 

set Defaults   Set Default SPEEDs and ACCELs 

activate 1. Robot  cRobot / SET / KR125-2 

Home Position   

select Tag 

 

select Tag Point T_BOX_1 

move to Tag  move to Box 

grab Box  GRAB [ ] / Grab „Bodyname“  /  BOX_1 

move away linear  LIN_Rel in Z by  -1000 mm 

select Tag 

 

select Tag Point T_CONV_1 

move to Tag  move to T_CONV_1 

release Box  Release [ ] / Release „Bodyname“  /  BOX_1 

move away linear  LIN_Rel in Z by -200 mm 

Home Position   

move Box   Move [ ] / Move_Rel „Bodyname“  /  BOX_1 in X=5200 
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Multi-KIN 
 

activate 2. Robot  cRobot / SET / IRB6400_M97 

select Tag 

 

select Tag Point T_BOX_G_2 

move to Tag  move to Tag Point T_BOX_G_2  

select Tag 

 

select Tag Point T_BOX_G_1 

move to  linear  move to Tag Point  T_BOX_G_1 linear  

grab Box  GRAB [ ] / Grab „Bodyname“  /  BOX_1 

move away linear  LIN_Rel in Z by -200 mm 

select Tag 

 

select Tag Point T_PALLETTE_2 

move to Tag  move to Tag Point T_PALLETTE_2  

select Tag 

 

select Tag Point T_PALLETTE_1 

move to  linear  move to Tag Point T_PALLETTE_1 linear 

release Box   Release [ ] / Release „Bodyname“  /  BOX_1 

Home Position   

save Program   
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Multi-KIN 
 

EASY-ROB™ Operation References 

 

Overview about the program 
 
 

ProgramFile 

 
! cRobot 'KR125-2' 
! Below section is called once at t=0 
! Add Initialization commands here 
!  
EndInit 
!  
! Below section is called at t>0 
! Add new ERPL / ERCL commands here 
! Set Default SPEEDs and ACCELs 
SPEED_PTP_AX    40.0000    40.0000    40.0000    40.0000    40.0000    40.0000 
ACCEL_PTP_AX    40.0000    40.0000    40.0000    40.0000    40.0000    40.0000 
SPEED_CP         0.2500 0.0 
ACCEL_CP         1.5000 
SPEED_ORI       20.0000 0.0 
ACCEL_ORI       40.0000 
OV_PRO         100.0000 
ERC NO_DECEL OFF 
ZONE             0.0000 
! --------- 
 
ERC CURRENT_DEVICE SET KR125-2 
Home 1 
MOVE T_BOX_1 
ERC GRAB BODY BOX_1 
LIN_REL  0.0000  0.0000  -1.000  0.0000  0.0000  0.0000 
MOVE T_CONV_1 
ERC RELEASE BODY BOX_1 
LIN_REL  0.0000  0.0000  -0.2000  0.0000  0.0000  0.0000 
Home 1 
 
ERC MOVE_REL BODY BOX_1  5.2000  0.0000  0.0000  0.0000  0.0000  0.0000 
 
ERC CURRENT_DEVICE SET IRB6400_M97 
MOVE T_BOX_G_2 
LIN T_BOX_G_1 
ERC GRAB BODY BOX_1 
LIN_REL   0.0000  0.0000 -0.2000  0.0000  0.0000  0.0000 
MOVE T_PALLETTE_2 
LIN T_PALLETTE_1 
ERC RELEASE BODY BOX_1 
Home 1 
 

EndProgramFile 

 
 
 
Begin of the Program 
 
 
 
 
 
 
 
 
 
Def. of speed and accelaration 
20 °/s 
40 °/s² 
250 mm/s 
1500 mm/s² 
20 °/s 
40 °/s² 
programmed override in percent 
No decelaration OFF 
Zone value = 0 
!-------- 
 
activate Robot 1  
move to Home position  
move to the Box 
grab the Box 
move away linear by 1000 mm 
move to Conveyer 
release the Box  
move away linear by 200 mm 
move to Home position 
 
move Box relativ 
 
 
activate Robot 2 
move to the Box 
move to  in linear mode 
grab the Box 
move away linear by 200 mm 
move to the Palette  
move to  in linear mode 
release the Box  
move to Home position  
 
end of Program 
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EASY-ROB™ Operation References 

Mini Tutorial 

Trajectory planning and -interpolation 

 

 
The task of the trajectory planner is to plan the path from start location A to target location B in the cartesian 
space so that the interpolation produces the desired axis values for the robot at every time step. For the 
trajectory planner, the motion types Synchro-PTP, SLEW, LIN and CIRC are available. The below pages show 
the dependency between position interpolation and orientation interpolation and the resulting different time- 
and motion behavior. 
 
To plan the path from A to B the following values must be set 
 

- Start- and target location  with orientation 
- Path- and orientation speed and accelerations 
- Motion type 
- Correlation between position- and orientation interpolation 

 
In the following example 4 points are programmed on a rectangle whereas two at a time have the same 
orientation. The table shows the point- or tag coordinates T2 - T5. 
 

tag X [mm] Y [mm] Z [mm] Rx [°] Ry [°] Rz [°] 

T2 250 500 300 0 180 0 

T3 1250 500 300 0 180 0 

T4 1250 0 300 -45 180 0 

T5 250 0 300 45 180 0 

 
To move along the edge of the rectangle the motion type LIN is chosen. The results are different cycle times 
depending on the selected interpolation method for orientation and position. The next table shows the path 
distances and the difference between the orientation angles of the tag points. 
 

from - to distance angle 

T2 - T3 1000 mm   0° 

T3 - T4 500 mm  45° 

T4 - T5 1000 mm -90° 

T5 - T2 500 mm  45° 

 
 
 
 
 
 
 
 
 
 
 

T2 T3 

T4 T5 

x 

y 

mailto:info@easy-rob.com
http://www.easy-rob.com/


 

Subject to change or improve without prior notice 98/108 

  
EASY-ROB Software GmbH  Hauptstr.42  65719 Hofheim am Taunus  Germany  Phone: +49 6192 921 70-77  FAX: +49 6192 921 70-66  info.er@easy-rob.com  www.easy-rob.com 

Trajectory planning and -interpolation 
 

 
 
The example  
motion_planning_01.cel  and the  
program  
motion_planning_01.prg  
(from TrainLib) will show the results 
for a KUKA robot KR 125-2  
 
 
 
 
 
 
 
 
 
 

 
ProgramFile 
 
SPEED_PTP_AX   20.0000   20.0000   20.0000   20.0000   20.0000   
20.0000 
ACCEL_PTP_AX   10.0000   10.0000   10.0000   10.0000   10.0000   
10.0000 
SPEED_CP         0.2000 0.0 
ACCEL_CP         0.1000 
SPEED_ORI       10.0000 0.0 
ACCEL_ORI       10.0000 
 
ZONE             0.0000 
 
LIN T_2 
! ------------------------------------------- 
ERC STATUS_OUTPUT ON  1  fname.dat 0 
! ------------------------------------------- 
LIN_ORI QUATERNION 
LEADING_POSITION ON 
!LEADING_ORIENTATION ON 
!LEADING_POSITION VAR 
 
call move() 
 
ERC STATUS_OUTPUT OFF 
! ------------------------------------------- 
PTP T_1 
EndProgramFile 
! ------------------------------------------- 
fct move() 
SPEED_CP         0.2000 0.0 
LIN T_3 
LIN T_4 
SPEED_CP         0.1000 0.0 
LIN T_5 
LIN T_2 
ERC STOP 
endfct 

 

 
Beginning of the program 
Definition of velocity and acceleration 
20 °/s 
 
10 °/s² 
 
200 mm/s 
100 mm/s² 
10 °/s 
10 °/s² 
 
Zone = 0  -> exact move to the target 
 
Move to start position T_2 
! ------------------------------------------- 
Write the x-, y- and z-position into the result file fname.dat 
! ------------------------------------------- 
Interpolation of the orientation by quaternion 
1. Try orientation-interpolation-type: position 
2. Try orientation-interpolation-type: orientation 
3. Try orientation-interpolation-type: variable 
 
Move along the rectangle over T_3, T_4, T_5 and T_2 
 
Close the result file fname.dat 
! ------------------------------------------- 
 
End of program 
! ------------------------------------------- 
Beginning of the function move() 
Move by 200mm/s to T_3 and T_4 
 
 
Move by 100mm/s to T_5 and T_2 
 
 
program stop 
End of function move() 
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Trajectory planning and -interpolation 
 

 
The three orientation-interpolation types 
 
Position and orientation are being separately planned when planning a path. This mostly results in different 
execution times. In practice it's desirable that position and orientation are synchronously interpolated. The 
type of interpolation for the orientation defines which of the planned execution times shall be dominant. 
 
 
LEADING_POSITION ON The execution time is defined by the position. Only if it's 0, the 

execution time resulting from the orientation is dominant. At small 
execution times the maximum orientation velocities can be exceeded 
what normally leads to higher joint velocities and -accelerations. 
 

LEADING_ORIENTATION ON The execution time is defined by the orientation. Only if it's 0, the 
execution time resulting from the position is dominant. At small 
execution times the maximum position velocities can be exceeded 
what normally leads to higher joint velocities and -accelerations. 
 

LEADING_POSITION VAR The time behavior is variable and defined by the current longer 
execution time. Except for singular positions an exceedance of the 
maximum joint velocities and -accelerations is avoided. 
Disadvantage: The process velocity is not constant. For this reason 
this type of orientation interpolation is not practical for applications 
like glueing, cutting, milling where the robot must move along a 
contour with constant velocity. 

 
 
The total execution time „total Time“ for all three types of orientation interpolation are displayed in the  
Robot IO Output window  „current Motion Data“. 
 
 
The following execution times result along the contour of the rectangle. 
 
 LEADING_POSITION   ON 28,5 s 
 LEADING_ORIENTATION   ON 28,0 s 
 LEADING_POSITION   VAR 29,5 s 
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Trajectory planning and -interpolation 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
LEADING_POSITION  ON: 

 
a) For the path from T_2 to T_3 with spos = 1000 mm using a programmed velocity of vpos = 200 mm/s 
and an acceleration of apos = 100 mm/s² a total time of ts_pos = 7 seconds is needed.  
 
 Acceleration time  tr1 = v/apos = 2,0 sec   sr1 = vpos

2/2apos = 200 mm 
 Deceleration time tr2 = v/apos = 2,0 sec   sr2 = vpos

2/2apos = 200 mm 
 Constant moving time tc = (spos - s r1 - s r1)/v = 3,0 sec  
 Total moving time  ts_pos = tr1 + tc + tr2= 7,0 sec 
 
b) For the path from T_3 to T_4  with spos = 500mm we get a total time of  ts_pos =4,5 seconds when 
doing the same calculation.  
The angle change of  = 45° results in a total time of ts_ori = 5,5 seconds when using a programmed 
orientation velocity of vori = 10 °/s and an orientation acceleration of aori = 10 °/s² 
 
 Acceleration time tr1 = vori/aori = 1,0 sec    r1 = vori

2/2aori = 5° 
 Deceleration time tr2 = vori/aori = 1,0 sec    r2 = vori

2/2aori = 5° 
 Constant moving time tc = (  -  r1 -  r1)/vori = 3,5 sec  
 Total moving time  ts_ori = tr1 + tc + tr2= 5,5 sec 
 
Case b) shows that the execution time ts_ori = 5,5s is bigger than ts_pos = 4,5s that result from the 
position calculation. In this case „LEADING_POSITION  ON“ the smaller execution time will be used. 
 

LEADING_ORIENTATION   ON: 
As a result of the inspection of case b) the execution time of the orientation interpolation will be 5,5 
seconds that in this case are dominant and will be used. 

 
LEADING_POSITION   VAR: 

When using this type of orientation interpolation always the maximum execution time is used. 
Because of this the total time will also be the maximum time. 
 

T_2 T_3 

T_4 T_5 

POS ON - 7,0 s 
ORI ON - 7,0 s 
POS VAR - 7,0 s 

POS ON - 4,5 s 
ORI ON - 5,5 s 
POS VAR - 5,5 s 

POS ON - 11,0 s 
ORI ON - 10,0 s 
POS VAR - 11,0 s 

POS ON - 6,0 s 
ORI ON - 5,5 s 
POS VAR - 6,0 s 
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Trajectory planning and -interpolation 
 

 
Result file „fname.dat“ 
 
The program line „ERC STATUS_OUTPUT ON  1  fname.dat  0“ creates the result file „fname.dat“  in the 
actual folder. The cartesian positions, joint angles and joint angle velocities are recorded into that file with 
every simulation step. The program line ERC STATUS_OUTPUT OFF   stops recording and closes the 
result file. 
 
Explanation of the columns in the result file: 
 
 column  1 :  leading number 
 column  2 :  time 
 column  3 :  position X in mm 
 column  4 :  position Y in mm 
 column  5 :  position Z in mm 
 columns  6-11: Joint angle of the axes 1 to 6 in [°] 
 columns  12-17:  Joint angle velocities of the axes 1 to 6 in [°/s] 
 
The result file for the motion from T_2 to T_5 using the orientation interpolation type LEADING_POSITION 
ON has been imported into a spreadsheet to show the cartesian velocities and accelerations for X- and Y-
direction in a chart. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The developing shows a continuous velocity- and acceleration profile without any jerk. 
 
Note:  The calculated maximum acceleration of 150 °/s² is about 50% higher than the 

programmed acceleration of 100 °/s². 
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Trajectory planning and -interpolation 
 

 
Note: 
 
For calculating jerk-free path motions with EASY-ROB™ the following settings must be done. 
 
 
 
Menu -> Robotics -> cRobotMotion Planner 
 
 Ipo Joint Code 
 Ipo CP Code 
 Ipo Circ Code 
 
 
 
 
 
 
 
 
 
 
Choose setting “2 - Jerkfree Vel-Prof. C3“ for the “Ipo CP Code API-IPO“ . 
 
 
 
 
1 - Geometric Vel-Prof. C0 Velocity and jerk are not limited 

without a velocity profile. 
 

2 - Jerkfree Vel-Prof. C3 Acceleration and jerk are 
continuous and limited when 
using a Jerk free velocity profile. 

 
 
 
Example files: 
 
 motion_planning_01.cel 
 motion_planning_01.prg 
 fname.xls 
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EASY-ROB™ Operation References 

Multi-Program 

Usage of digital signals  

 

 
In a simulation with more than one program in the workcell (Multi-Program) the devices have to 
communicate. In EASY-ROB™ this will be done by digital signals. 
Basically it not very complex to program with digital signals. But this can change very quick if the workcell 
and the number of the communication devices is growing or if the programmer is ignoring recommended 
basic rules. 
 
 
Recommended basic rules: 
- always initialize the signals at the beginning the corresponding robot program in area for initialization  
- always set the signals while initialization to zero (off) 
- always use “meaningful” names for the signals – that helps to keep overview 
- always program the communication “step by step” respectively one pair of devices and check straight 

away for a correct communication 
 
 
Always work along the following principle: 

1. If the signal is not set -  then device „A“ will set its signal 
2. Device „B“ will wait until the signal of device „A“ is set and 
3. Device „B“ will unset (reset) straight away the signal of device „A“ 

 
 
 
The following extract of programs will show the procedure: 

1. the robot places a object onto the conveyor 
2. if the signal is not set up to now, the robot will set the signal to „1“ and tell the conveyor on this way 

that the object arrived 
3. the conveyor is waiting for the signal of the robot 
4. the conveyor unsets the signal of the robot 
5. the conveyor moves the object forward and backward and release is again 
6. the conveyor sets the signal to„1“  to tell the robot that its back 
7. the robot waits for the signal of the conveyor 
8. the robot unsets the signal of the conveyor  
9. the robot takes the object and moves away 

 

 

mailto:info@easy-rob.com
http://www.easy-rob.com/


 

Subject to change or improve without prior notice 104/108 

  
EASY-ROB Software GmbH  Hauptstr.42  65719 Hofheim am Taunus  Germany  Phone: +49 6192 921 70-77  FAX: +49 6192 921 70-66  info.er@easy-rob.com  www.easy-rob.com 

Multi-Program – Usage of digital signals 
 

Example 

Robot program (extract) Conveyor program (extract) 

…..  
1. ERC RELEASE DEVICE BOX_TUTORIAL  
2. WAIT_UNTIL_SIGNAL_UNSET rob01_out  
2. rob01_out=1 3. WAIT_UNTIL_SIGNAL_SET rob01_out 
 4. rob01_out=0 
 5. ERC GRAB DEVICE BOX_TUTORIA 
 5. PTP T_CONV_2 
 5. PTP T_CONV_1 
 5. ERC RELEASE DEVICE BOX_TUTORIAL 
 6. WAIT_UNTIL_SIGNAL_UNSET conv_out 
7. WAIT_UNTIL_SIGNAL_SET conv_out 6. conv_out=1 
8. conv_out=0  
9. PTP T_BOX_TOP_1  
9. ERC GRAB DEVICE BOX_TUTORIAL  
…..  
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EASY-ROB™ Operation References 

Internet Links 
 
- EASY-ROB™  

 
Link: https://easy-rob.com/en/downloads-2/ 
 
Operation References for EASY-ROB™  
 operation-references.pdf  
 
Operation References for EASY-ROB™ Special Functions & PlugIns 
 operation-references-functions-plugins.pdf 
 
ERPL/ERCL - EASY-ROB™ Command Language 
 easy-rob-erpl_eng.pdf 
 

- EASY-ROB™ Newsletter 
 
Link: https://easy-rob.com/en/downloads-2/ 

 
Year 2018 
Topic: Release 7.6 – The new Version update-info-v76-eng.pdf 

 
Year 2017 
Topic: Release 7.3 – The new Version update-info-v73-eng.pdf 

 
Year 2016 
Topic: Release 7.0 – The new Version update-info-v70-eng.pdf 
 
Year 2015 
Topic: Release 6.6 – The new Version update-info-v66-eng.pdf 
 
Year 2014 
Topic: Release 6.3 – The new Version update-info-v63-eng.pdf 
 
Year 2012 
Topic: Release 6.0 – The new Version news-04-12-e.pdf 
 
Year 2011 
Topic: Release 5.6 – The new Version news-04-11-e.pdf 
 
Year 2010 
Topic: Release 5.3 – The new Version news-02-10-e.pdf  
 
Year 2009 
Topic: Release 5.006 – Update news-07-09-e.pdf  
 
3rd/4th Quarter 2008 
Topic: Release 5.0 – The new Version news-10-08-e.pdf  
 
1./2. Quarter 2008 
Topic: Release 4.606 – Project Manager news-03-08-e.pdf  
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http://www.easy-rob.com/uploads/media/operation-references-functions-plugins_01.pdf
http://www.easy-rob.com/uploads/media/easy-rob-erpl_eng.pdf
https://easy-rob.com/en/downloads-2/
http://www.easy-rob.com/uploads/media/Update-ER_v7605-2018_ENG_01.pdf
http://www.easy-rob.com/uploads/media/Update-ER_v7305-2017_ENG_01.pdf
http://www.easy-rob.com/uploads/media/Update-ER_v7004-2016_ENG_01.pdf
http://www.easy-rob.com/uploads/media/update-er_v6601-2015_eng.pdf
http://www.easy-rob.com/uploads/media/update-info-v63-eng.pdf
http://www.easy-rob.com/uploads/media/Update-Info-v60-eng.pdf
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Internet Links 
 

4th. Quarter 2007 
Topic: Release 4.603 – Multi-Program news-11-07-e.pdf 
 
3rd Quarter 2007 
Topic: Release 4.307 – update news-08-07-e.pdf 
 
1st/2nd Quarter 2007 
Topic: Release 4.305 – The new Version news-01-07-e.pdf  
 
3rd/4th Quarter 2005 
Topic: New functionality for multiple kinematics news-09-05-e.pdf 
 
1st/2nd Quarter 2005 
Topic: Release 4.0 with multiple kinematics news-03-05-e.pdf  
 
3rd/4th Quarter 2004 
Topic: Customized solutions with the EASY-ROB™ API news-10-04-e.pdf  
 
2nd Quarter 2004 
Topic: EASY-ROB™ Robotics Simulation Kernel  
integrated into Offline programming system FAMOS® news-06-04-e.pdf  
 
1st Quarter 2004 
Topic: Video Mode for Simulations news-03-04-e.pdf  
 
4th Quarter 2003 
Topic: Your new Companion – EASY-ROB News news-11-03-e.pdf  

 
- Prof. Dr. Thomas Horsch: 

Introduction to Robotics: „Module Trajectory generation and robot programming” 
FH Darmstadt, Summer 2000,  
Link: http://www.easy-rob.com/en/service/articles-publications.html 
 LectureRobotics.pdf 
 

- Prof. Heribert Münch, Dipl.-Ing. J. Bargfrede: 
„Universelle Koordinatentransformation für Industrieroboter“ 
Hochschule Magdeburg-Stendal, August 2001,  
Link: http://www.easy-rob.com/service/artikel-publikationen.html 
 paper_unitrans.pdf 
 

- Janko Härtig: Praktikumsarbeit bei EASY-ROB™ 
Roboterkinematiken „Direkte- und inverse Koordinatentransformation“ 
Hochschule Mittweida (FH), Juli 2004,  
Link: http://www.easy-rob.com/service/artikel-publikationen.html 
 bps-inverse-kinematik-jhaertig.pdf 
 

- Dipl.-Ing. S. Anton: 
„Inverse Kinematik am Robotersimulationsprogramm EASY-ROB™“ 
1. Workshop Robotik, Hochschule Mittweida (FH), Oktober 2004,  
Link: http://www.easy-rob.com/service/artikel-publikationen.html 
 EASY-ROB-Inverse-Kinematik.pdf 
 
Link:  http://www.global.hs-mittweida.de/~ifa/archivrobotik.htm 
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EASY-ROB™  

 

Contact 
 

 
 

EASY-ROB Software GmbH 
 

Address:  Hauptstr. 42 

   65719 Hofheim am Taunus 

   Germany 

 

Contact:  Mr. Stefan Anton 

 

Phone:  +49 6192  921 70 77/ -79 

FAX:   +49 6192  921 70 66 

 

Email:   contact@easy-rob.com 

   sales@easy-rob.com 

 

Url:   www.easy-rob.com 

 

 

EASY-ROB customer area 
 
Content:  Program updates and robot libraries 

 
Web:   www.easy-rob.com/en/downloads-2/client-area/ 

 
Log in data: 
   User name: customer 

   Password: ********** 
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EASY-ROB™  

 

Notes 
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