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EASY-ROB™ V5.6 
 

Highlights in EASY-ROB™ V5.6  
 

• EASY-ROB™ als 64-Bit Version verfügbar  
Die gesamte EASY-ROB™ Product Suite bestehend aus Single-Robot  und Multi-Program  
Version, der DLL Version  und dem Simulations Kernel  steht nun als 64-Bit Version zur Verfügung. 
Das erlaubt die vollständige Nutzung des verfügbaren Arbeitsspeichers unter Window® 7 64-Bit. 
 

• Navigation und Bedienung 
Ein Center Of Interrest “COI“ erleichtert die Navigation durch die 3D Szene. Im Auto-Modus befindet 
sich der COI stets am aktuellen Objekt und bildet so den Cruise-Mittelpunkt. 
Zusätzlich kann mit F8 des aktuelle Objekt oder die ganze Welt gezoomt werden. 
 

• Space Mouse Anbindung 
EASY-ROB™ unterstützt die 3D Mouse (Space Mouse) von 3DConnexion. Die dreidimensionale 
Navigation durch die Roboteranlage erfolgt intuitive und präzise. 
 

• CAD2ER 
Die Konvertierung von STEP- und VRML II Daten in das eigene IGP Format wurde vollständig als 
eigenständige Applikation ausgelagert und steht als 32-Bit Applikation zur Verfügung. 
 

• CAD Daten Export 
Einzelne Roboter und Devices oder gar die gesamte Arbeitszelle können als binary STL Format 
exportiert werden. STL binary ist ein neutrales Format und kann in alle gängigen CAD Systeme 
importiert werden. Die Ergebnisse des Planers können so vom Konstrukteur weiterverarbeitet 
werden. 
 

• IGP auch im binary Format 
IGP kann nun als binäres Format gespeichert und auch gelesen werden. Die Dateigröße reduziert 
sich um gute 50%. Beim Einlesen werden bis zu 20% Zeit erspart. 
 

• Neue Roboter 
Die  Roboterbibliothek hat wieder Zuwachs bekommen. Neue Modelle von ABB, Kuka, Stäubli, 
Fanuc, Motoman und OTC sind hinzugekommen. 
 

• Pfade und Tag Punkte 
Die  Pfade lassen sich nun Robotern zuordnen “Path Owner“, was erheblich zur Übersichtlichkeit 
beträgt wenn die Arbeitszellen groß werden. Wird ein Tag angewählt, ist der zugehörige Roboter 
automatisch aktiv. 
Tag Punkte eines Pfades werden nun entsprechend dem Motion Type verbunden. Visuell lässt sich 
sofort erkennen wie die Bahn bei CP Bewegungen (LIN und CIRC) aussieht. PTP Bewegungen 
werden gestrichelt dargestellt. 
Pfade können nun in verschiedenen ASCII Formaten exportiert und auch wieder importiert werden. 
Für ABB Rapid S4 und KUKA KRC gibt es einen generischen Export. Somit können Robtargets aus 
EASY-ROB™ in ein ABB/KUKA Programm übernommen werden. Das soll für weitere Sprachen wie 
z.B. COMAU etc. erweitert werden. 
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• Motion Planning und Interpolation 
Für die Zirkular-Orientierungsinterpolation gibt es nun die Möglichkeit die vorgegebene Orientierung 
im Via-Punktes auf der Kreisbahn genau anzufahren, so wie es die Stäubli- und die Fanuc 
Steuerung ermöglichen. 
Bei der Verfahrart Synchro-PTP kann die Zielkonfiguration (config) variable gehalten werden. Hierbei 
wird als Zielwinkel- bzw. Zielachsstellung die Lösung mit den kleinsten Änderungen genommen. 
(nearest solution). Die resultierende Bewegung sieht oft nicht nur eleganter aus, sondern kann in der 
Regel auch schneller erreicht werden. 
 

• Simulation, ERPL 
Die Perspektive kann im Simulationslauf wieder interpoliert werden. 
Hinzugekommen sind wieder nützlich ERPL und ERCL Befehle 
 

• Referenz-Kinematik 
Redundante Kinematiken und Kinematiken ohne analytische Lösung konnten bisher nur mit einem 
numerischen Lösungsverfahren im kartesischen Raum verfahren werden. Ist man einerseits über 
diese Lösung froh, erweist es sich als Nachteilig, dass der Roboter sich stets nur in einer aktuellen 
Konfiguration bewegt. Ein Umkonfigurieren ist nur umständlich möglich. Mit dem neuen 
Lösungsverfahren „Referenz-Kinematik“ können nun alle Konfigurationen angefahren werden. 
 

• NC Simulation 
Der NC Interpreter unterstützt die G-Codes G17, G18 und G19, welche die Ebene für die 
Kreisinterpolation festlegen. 
 

• API Application Program Interface, die Klasse CAPI 
Für die individuelle Produktanpassung und spezielle Lösungen sind viele neue API Funktionen 
hinzugekommen. Diese ermöglichen es EASY-ROB™ aus einer eigenen Applikation anzusteuern 
bzw. bidirektional Daten auszutauschen. 
 

 
Die neue Version steht für alle Kunden mit einer gültigen Lizenz für EASY-ROB™ V5.6 kostenfrei zur 
Verfügung. Für Kunden älterer Versionen besteht die Möglichkeit ein Update zu erwerben. Für Ihre 
Anregungen und Verbesserungsvorschläge bedanken wir uns schon jetzt bei Ihnen. 

 
Vielen Dank 

 
Stefan Anton 

EASY-ROB  
3D Robot Simulation Tool 
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64-Bit Version 
Mit EASY-ROB™ V5.6 stehen alle Produkte (Single-Robot  Version, Multi-Program  Version, DLL Version 
und Simulations Kernel ) als 64-Bit Version zur Verfügung. 
 
Unter Window® 7  64-Bit kann so der gesamte verfügbare Speicher genutzt werden. Insbesondere bei 
großen Datenmodellen macht sich dieser Vorteil bemerkbar. So wird bei der 32-Bit Version die 2.2 - 3 GB 
Grenze recht schnell erreicht. Erste Tests sind sehr viel versprechend verlaufen. Somit lohnt es sich wieder 
Grafikkarten mit hoher Performance zu verwenden und den Rechner mit ordentlich Speicher zu vestücken. 
Ein Vergleich bzgl. der Simulationsgeschwindigkeit ergibt gegenüber der 32-Bit Version keinen 
nennenswerten  Unterschied. 

Bedienung 

Die Bedienung ist unverändert. Insofern wird der Bediener zwischen der 32- und 64-Bit Version keinen 
Unterschied erkennen. Arbeitszellen, Roboterfiles und Programmdateien sind sowohl in der 32-Bit als auch 
in der 64-Bit Version lauffähig. Bei ersten Tests empfehlen wir jedoch eine Kopie Ihrer Dateien anzulegen. 
IGP, STL und 3DS Dateien müssen nicht gesichert werden, diese werden in der Regel nur gelesen wenn 
Roboter oder Zellen geladen werden. 

API 

Auch die Programmierschnittstellen bleiben in der 64-Bit Version unverändert. Eigene Projekte müssen 
natürlich auf 64-Bit umgestellt und neu kompiliert werden. Die Preprocessor Definition „_WIN64“ ist hierbei 
nicht zu vergessen, siehe z.B. “/er_dvlp/ ER_CAPI_TYPES.H“. Letztlich muss gegen die EASY-ROB™ 
Library „easyrobwx64.lib“gelinkt werden. Wir haben uns entschieden sämtliche 64-Bit Dlls mit dem Postfix 
x64 zu versehen. Aus „easyrobw.exe“ wird „easyrobwx64.exe“ und aus „er_tbox.dll“ wird „er_tboxx64.dll“. 

Ausnahmen 

1. Bei der aktuellen 64-Bit Version können keine AVI Videos erzeugt werden. Diese Funktionalität 
soll in kommenden Patches nachgeliefert werden. 
 

2. Der „ältere“ Kollisions-Algorithmus OpCode konnte nicht nach 64-Bit portiert werden. Hier steht 
der „neuere“ und auch leistungsfähigere Kollisions-Algorithmus zur Verfügung, der seit Version 
5.3 implementiert wurde. 
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Navigation und Bedienung 
 
In der neuen Version ist die Bedienung und Navigation verbessert worden.  
 

• Sämtliche Dialoge sind nun mit ToolTips „Werkzeughilfen“ versehen. Beim kurzzeitigen Verweilen 
auf die Schaltfläche im Dialog erscheint  ein kurzer Beschreibungstext. 

 
 

• Die gesamte Menuleiste kann ausgeblendet werden 
Menu: View > Menu  F10 
Die Menuleiste wird mit F10 wieder eingeblendet 
 

• Anwender die mit verschiedenen 3D Software Tools (CAD Systeme etc.) arbeiten, können nun die 

Tastenbelegung für den Cruise Modus  in der Umgebungsdatei (Alt+Shift+E) „easy-rob.env“ 
anpassen. 
 
Für EASY-ROB™ gilt: 
CRUISE_ROT_FLAGS  LMB press LMB to rotate the world 
CRUISE_ZOOM_FLAGS     MMB press MMB to zoom in or out 
CRUISE_ZOOM2MB_FLAG   RMB zoom setting if '2 Mouse Buttons' is enabled 
CRUISE_PAN_FLAG      LMB  RMB press LMB+RMB to pan the world 
 
Die Grundeinstellung kann im Menu: View > Set 3D View > Reset Cruise Flags 
wieder hergestellt werden. 
 
Tipp: 
Beispieleinstellungen werden beim speichern der Umgebungsdatei erzeugt 

 

Center Of Interest COI 

 
Im Cruise Mode Auto (Standard-Einstellung) wird der COI der 3D Szene automatisch gesetzt. Das geschieht 
beim Anwählen „Picken“ einer Geometrie, eines Roboters, Tags oder Polygons oder z.B. eines Punktes. 
Kombiniert mit der F8-Taste wird der COI in den Bildschirm-Mittelpunkt gezoomt.  
 
Der COI wird als kleine transparente rote Kugel  
visualisiert, die im Navigator Window auch 
abgeschaltet werden kann. 

 

 
COI im Weltursprung 
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Zoomen 

 
Die neue Zoomfunktion erleichtert es erheblich die angewählten Objekte in den sichtbaren Bereich des 
Bildschirms zu schieben und gleichzeitig um deren Mittelpunkt die 3D Szene zu drehen. 
 
Im Menu: View > Set 3D View > Zoom 
 
Kann die gesamte Welt, der cRobot, cTag etc. in die Bildschirmmitte gezoomt 
werden. 
 
 
1. Beispiel: 

Laden Sie einen beliebigen Roboter und öffnen das 3D CAD Window 2 x  

Wählen Sie mit  einen Körper aus.  
Drücken Sie nun F8 oder im View Menu: Zoom cBody. 
Die angewählte Geometrie wird in die Mitte des Bildschirms gezoomt und 
bildet den Center Of Interest (COI). 
 
Tipp: 
Durch Drücken der Leertaste/space-bar kann kann zwischen “Pick“- und 
“Cruise“ Mode schnell hin- und hergeschaltet werden.  
 
 
2. Beispiel:  
Picken Sie einen Punkt an einer Geometrie, so dass der Punkt der COI wird. 
Öffnen Sie hierzu das Navigator Window (CTRL+N) 
 
Wählen Sie, 
Point Measure und Vertices und 

 
und „picken“ einen Punkt an der 
Geometrie 
Drücken Sie nun F8, so wird der Punkt 
in die Mitte des Bildschirms gezoomt 
und bildet den Center Of Interest (COI). 
  

 
 

 

 
View > Set 3D View > Zoom 
 

 
Der COI  befindet sich in der 
Mitte der ausgewählten 
Geometrie 
 

Der COI  befindet sich am 
angewählten Punkt/Vertex der 
Geometrie 
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Messen von Kreismittelpunkten 

 
Seit der letzten Version 5.3 kann durch Messen von 3 Punkten der Kreismittelpunkt bestimmt werden. In der 
neuen Version werden zusätzlich die Messwerte wie Radius, Bogenlänge und Winkel angezeigt. 
 
 
Wählen Sie, im Navigator Window 
 

3 Point Circle Measure und Vertices und  
und „picken“ drei Punkte an der Geometrie 
 
Die Reihenfolge der Messpunkte bestimmt den Normalen 
Vektor und die Richtung des Kreisbogens. 
 
  

 

      
1. Messpunkt 2. Messpunkt 3. Messpunkt,  
  Ergebnis: R= 80, Phi= 124°, Arc=  173 
 
Tipp: 
Drücken Sie die Esc-Taste, wenn Sie einen falschen Punkt erwischt haben, er wird dann gelöscht. 
Um einen neuen Tag Punkt im Kreismittelpunkt zu erzeugen drücken Sie einmal die mittlere und 
anschließend rechte Maustaste. 
 

Darstellung von Koordinatensystemen 

 
Damit Koordinatensysteme, wie z.B. auch Tags, 
Geometrie-Punkte nicht mehr verdecken werden diese neu 
dargestellt.  
 
Der Ursprung ist bei der Darstellung freigeschnitten. 
„Punkte/Vertices“ können somit eindeutiger angewählt 
werden. 
 
Weiterhin wird die Größe von Tags beim Zoomen 
angepasst, so dass sie beim Heran- und Wegzoomen nicht 
mehr beliebig  groß bzw. klein werden. 

 
New coorsys visualization 
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Near- und Farplane 

Die Einstellung der Near- und Far Plane (Clipping planes) erfolgt nun interaktiv durch ziehen mit der Maus. 
 
Wählen Sie, im Navigator Window 
 
Menu Mouse Mode > Near Far Plane 
 
Ziehen Sie mit dem  
LMB um die Near Plane und den 
RMB um die Far Plane zu verschieben. 
 
Alternativ können auch die Werte  
Menu: View > Grafic View Data 
Eingegeben werden 

 

 

 
 

 

 
 

 

 
 

Floor und Background Color 

 
Lassen sich nun direkt im Color-Dialog eingeben. 
 
Menu View >Floor  > Floor Color 
Menu View >Render > Background Color 
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Space Mouse Anbindung 
 
Navigieren Sie durch die 3D Szene mit der 3D Mause (Space Mouse) von 3DConexion. 
Die dreidimensionale Navigation durch die Roboteranlage erfolgt intuitive und präzise 
 

  
 Bild: 3DConnexion 
 
Tastenbelegung beim Space Explorer (siehe auch Anzeige im Status Bar) 
 

 
1  Toggles  -> PanZoom  

 -> Rotate  
 -> Pan+Rotate 

 
2  Toggles  -> Cruise World  

 -> Jog cTcp  
 -> Jog cRobot Joints 

 
Shift  wie Keyboard 
Esc  wie Keyboard 
Ctrl   wie Keyboard 
Alt   wie Keyboard 
 

 

 
-   Reduziert Empfindlichkeit 
 
+   Erhöht Empfindlichkeit 
 
 
T  Top View 
L  Left View 
2D  ohne Funktion 
R  Right View 
F  Front View 
 
 

 Panel  Open Menu 
Fit   Zoom World, cRobot, cTag, .. 
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CAD2ER 
 
Mit EASY-ROB™ - CAD2ER werden STEP- und VRML II,97 Dateien nach IGP konvertiert. 
Die Anwendung ist ausgelagert und befindet sich als eigenständige Applikation im Unterverzeichnis 
./cad2er/ der EASY-ROB™ Applikation. 
Geöffnete Rob- und IGP- Dateien werden in einer neuen EASY-ROB™ Sitzung geladen. 
 
Starten Sie CAD2ER mit der Tastenkombination Ctrl+Shift+C oder im 
Menu: Load > Start CAD2ER Converter 
 

 
CAD2ER ist in Zusammenarbeit mit machineering GmbH & Co. KG (www.machineering.de) entstanden. 
machineering entwickelt Softwarelösungen für die 3D-Simulation und virtuelle Inbetriebnahme im Maschinen- und Anlagenbau. 

 
 
Bedienung 

• Wählen Sie die zu konvertierende Datei mit  aus. 
• Ändern Sie ggf. den Namen der Ausgabedatei „Output File“ 
• Checken Sie „User Color“ um die Farbe später in EASY-ROB™ festzulegen. 

• Wählen Sie  um die Konvertierung zu starten 
• Doppelklicken Sie den erzeugten Dateinamen in „[]“ Klammern um die Datei in einer neuen  

EASY-ROB™ Sitzung zu öffnen. 

• Beenden Sie CAD2ER mit  
 

Tipp: Native CAD Daten, wie CATIA V4/V5 oder Pro/Engineer, können z.B. mit der Software „3D-Tool“ 
nach STEP konvertiert werden. 
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CAD Daten Export 
 
Einzelne Roboter und Devices oder gar die gesamte Arbeitszelle können als binary STL Format exportiert 
werden. STL binary ist ein neutrales Format und kann in alle gängigen CAD Systeme importiert werden. Die 
Ergebnisse des Planers können so vom Konstrukteur weiterverarbeitet werden.  
 
Optional kann das exportierte STL Format auch Farben beinhalten, was jedoch leider nicht alle CAD 
Systeme unterstützen. 
 

 
Arbeitszelle: arcweld_L_01.cel 

Zum exportieren Roboters wählen Sie den 
Roboter aus und im  
Menu: File > Save > Export > STL binary, 
so dass sich das CAD Export Window  öffnet 
 

 
 

Die Auswahl „cDevice with childs“ exportiert den 
Roboter mit der Schweißpistole als farbige STL 
Datei z.B. „cDeviceChilds_stl“. 

   
Roboter als STL binary file Drehtisch als IGP binary file 

 
Arbeitszelle als VRML II,97 file 

 
Um z.B. den Drehtisch „POSITIONER_01“ mit 
Bauteil „WORKPIECE_02 „ als IGP binary  zu 
exportieren, muss der Drehtisch ausgewählt 
werden. 
 

 
 
Beim neuen Format IGP binary schrumpft die 
Dateigröße auf gute 50%. Das Einlesen wird um 
20% beschleunigt. Alle Geometrien werden in 
Weltkoordinaten gespeichert. 
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IGP auch im binary Format 
 
Das interne IGP Format kann nun im binary Format gespeichert und auch gelesen werden. 
Die Dateigröße reduziert sich um fast 50%. Beim Einlesen werden bis zu 20% Zeit erspart. 
 
IGP binary b11 besteht nur aus triangulierten Daten 
 
Aufbau des Formats 
 
 IGPHeader 80 bytes "b11 EASY-ROB IGP binary Export er v1.0 ..."; 
   --> detection key 'b11' -> binary and version 11  
 
 OBJHeader 16 Bytes int n_coorsys int n-obj 0 0 
 
 if (n_coorsys) 
   OBJ_COORSYS 48 Bytes float n[3],o[3],a[3],p[3] 
 
 if (n_obj) 
   OBJHeader 16 Bytes int color_idx n_points n_line s n_poly 
 
 read complete object content, with  
  n_obj_size = n_point*sizeof(VERTEX)+ n_line*sizeo f(LINESEG)+  
   n_poly*sizeof(TRIPOLY); 
  --> obj_content 
 if (n_points>0) get vertices from obj_content 
 if (n_lines>0)  get lines from obj_content 
 if (n_poly>0) get triangulated polygons from obj_c ontent 
 
 go for next object 

 
mit den Daten-Typen 
 

typedef  struct  { char  id[80]; } IGPHeader;   // 80 Bytes  
typedef  struct  { int  iv[4]; // n_coorsys n-obj 0 0 ;  
  or color_idx n_points n_lines n_poly  
  } OBJHeader;   // 16 Bytes  
typedef  struct  { float  n[3],o[3],a[3],p[3]; } OBJ_COORSYS;  // 48 Bytes  
typedef  struct  { float  x[DIM]; } VERTEX;  // 12 Bytes  
typedef  struct  { int  l[2]; } LINESEG;   // 8 Bytes  
typedef  struct  { int  i[3]; } TRIPOLY;   // 12 Bytes  
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Neue Roboter 
 
Die  Roboterbibliothek hat wieder Zuwachs bekommen. Neue Modelle von ABB, Kuka, Stäubli, Fanuc, 
Motoman und OTC sind hinzugekommen 
 
Einige Beispiele 
 
ABB Roboter 
 

IRB-120-3-0,6.rob 
IRB-260--30-M2004.rob 
IRB-540-12-10.rob 
IRB-540-1620-M96.rob 
IRB-6660_205_190.rob 

 

  
IRB-260--30-M2004 IRB-6660_205_190 
 

COMAU Roboter 
 

SM-NH3-165-3,0.rob 
SM-NH3-220-2,7.rob 
SM-NM-16-3,1.rob 

 

  
SM-NM-16-3,1 SM-NH3-165-3,0 
 

KUKA Roboter 
 

KR180L100_2k.rob 
KR180L100K_2K.rob 
KR360-2 
KR360-L280 
KR360-L240 
KR500-2 
KR500-L420 
KR500-L340 
KR90-R2700-pro 
KR90-R3100-extra 

 

  
KR-500-L420-- KUKA-LBR.jpg 
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Neue Roboter 
 
 
OTC-Daihen Roboter 
 

AII-B4.rob 
AII-B4L.rob 
AII-PF-XXX.rob 
AII-PH-501.rob 

 

  
AII-B4 AII-PH-501 

 
Staubli Roboter 
 

CS8-Controller.rob 
CS8-PENDANT.rob 
CS8-STOP.rob 
TS40-STD-FL.rob 
TS60-STD-FL.rob 
TS80-STD-FL.rob 
TX200--100-.rob 
TX200-L-60-.rob 

 
  

TX200-L-60- TS60-STD-FL 

 
Schunk Roboter 
 

LWA3 - Ultra Light Weight  
  Arm Version 3 
 

 
LWA3.jpg 
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Pfade und Tag Punkte 
 

Path Owner 

Pfade lassen sich nun Robotern zuordnen “Path Owner“, was erheblich zur Übersichtlichkeit beträgt wenn 
die Arbeitszellen groß werden. Wird ein Tag angewählt, ist der zugehörige Roboter automatisch aktiv. 
 
 
Mit einem Doppelklick auf “Path Owner“ im Tag 
Window kann der Roboter ausgewählt werden zu 
dem der Path gehört, hier ist es der „ER431“ 
 

 
 

 
 
Die Verbindung kann auch wieder gelöst werden. 
 

 

 
 
 

Motion Type Visualisierung 

 
Wird jedem Tag-Punkt ein „motion type“ wie  PTP, LIN, VIA oder CIRC zugewiesen, wird dieser Zustand 
grafisch dargestellt. 
 

 

Motion Type nicht definiert , dunkel gestrichelt 

 

Motion Type PTP, gelb gestrichelt 

 
Motion Type CP LIN, gelb durchzogen 

 



 

 Technische Änderungen und Verbesserungen sind vorbehalten 19/28 
  
EASY-ROB™ Stefan Anton Hans-Thoma-Str.26a 60596 Frankfurt/Main Germany Tel. +49 69 677 24-287  Fax. +49 69 677 24-320  info.er@easy-rob.com  www.easy-rob.com 
 

 
 Update EASY-ROB™ V5.6 
 
 

 

Motion Type CP VIA -> CIRC, gelb durchzogen 

 

Motion Type ungültig , rot durchzogen 
 
z.B. Zwei Tags mit dem Motion Type CIRC folgen 
aufeinander 

 
Path mit verschiedenen Motion Types 

 
Path mit geänderter T_Via Position, das 
Kreissegment wird sofort aktualisiert. 

Path Export 

 
Pfade können nun in verschiedenen ASCII Formaten exportiert und auch wieder importiert werden. 
Tag-Menu > File > Save > Export cPath 
 
Die ersten 4 Varianten speichert alle  
Tag-Positionen des aktuellen Path „cPath“ als 
1. xyz ijk 

0.00 0.00 700.00  0 0 -1 T_PTP 
600.00 0.00 700.00  0 0 -1 T_LIN 

2. xyz RxRyRz 
0.00 0.00 700.00  180 0 0 T_PTP 
600.00 0.00 700.00  180 0 0 T_LIN 

3. xyz RxRyRz + Tag-Attributes   
[motype, render, speed_ptp_ov, speed_cp, speed_ori, 
configuration] 
0.00 0.00 700.00  180 0 0 T_PTP  
 0 0.0000 0.0000 0.0000 0 
600.00 0.00 700.00  180 0 0 T_LIN  
 2 0 0.0000 0.0000 0.0000 0 
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4. xyz noa Frame 

0.00 0.00 700.00  1 0 0  0 -1 0  0 0 -1  T_PTP 
600.00 0.00 700.00  1 0 0  0 -1 0  0 0 -1  T_LIN 

 
Solche ASCII Dateien können auch von externen Anwendungen erzeugt werden, so dass Zielpositionen wie 
z.B. Messpunkte etc. als Path in EASY-ROB™ importiert und weiterverarbeitet werden können. 
 
Die Variante „5 – EASY-ROB Program ” schreibt für den cPath ein ERPL Programm heraus. Hierbei werden 
die Zielpositionen als Zahlenwerte bzgl. der Roboterbasis herausgeschrieben. 
 

ProgramFile 
! 
SPEED_PTP_OV   80.0000 
SPEED_CP_OV    80.0000 
SPEED_ORI_OV   80.0000 
OV_PRO   100.0000 
ERC NO_DECEL OFF 
ZONE   0.0000 
! 
ERC TRACK ON 
! 
BASE 1.3228 0.2826 0.0500 0.00000 0.00000 0.00000 
! 
TOOL 0.0000 0.0000 0.0000 0.00000 0.00000 0.00000 
! 
PTP   0.00000 0.00000 0.70000 180.000 0.000 0.000 
LIN   0.60000 0.00000 0.70000 180.000 0.000 0.000 
! 
EndProgramFile 

 
Die Variante „6 - FAMOS Point Data “ exportiert ein Point Data file für die OLP Software FAMOS robotic®. 
Diese Point Data files (*.pis) können auch von FAMOS generiert und wieder in EASY-ROB™ importiert 
werden. 
 

Syntax einer .pis Datei: n o a p 
1 1 1 0 1 0 0 0 1 0 0 0 
-0.0871558 0.0000000 -0.9961947 0.0000000 1.0000000  0.0000000 0.9961947 0.0000000 -0.0871558 

1699.239 0.000 2232.569 
-0.0718273 -0.0493656 -0.9961947 -0.5664063 0.82412 62 -0.0000001 0.8209901 0.5642509 -

0.0871557 949.923 652.864 2280.380 
-0.0571793 0.0657772 -0.9961947 0.7547101 0.6560584  -0.0000001 0.6535619 -0.7518381 -0.0871557 

756.201 -869.911 2280.380 
-0.7824137 0.1950773 -0.5914166 0.2419214 0.9702958  0.0000000 0.5738491 -0.1430763 -0.8063661 

1849.237 -461.066 1865.039 

 
Die Varianten „7 - ABB Rapid Program “ und „8 - KUKA KRL Program “ ermöglichen es für ABB Rapid S4 
und KUKA KRC einen generischen Export zu erzeugen. Somit können „robtargets“ aus EASY-ROB™ in ein 
ABB/KUKA Programm übernommen werden. Diese Funktionalität wird für Sprachen anderer 
Roboterhersteller wie z.B. COMAU, Stäubli etc. erweitert. 
 

Beispiel ABB Rapid Export 
%%% 
  VERSION:1 
  LANGUAGE:ENGLISH 
%%% 
MODULE MY_PROG 
! -------------------------------------------------  
! Path Export 
! EASY-ROB 3D Robot Simulation Tool 
! Copyright (c) 1996-2011 
! -------------------------------------------------  
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! -------------------------------------------------  
! Declaration of common variables 
! -------------------------------------------------  
 PERS LoadData lDef:=[10,[0,0,0.1],[1,0,0,0],0,0,0] ; 
 PERS ZoneData zDef:=[FALSE,0,0,0,0,0,0]; 
 PERS SpeedData vDef:=[0.05,500,5000,1000]; 
 
 PERS WobjData WOBJ01:=[FALSE,TRUE,"",[[-0.000000,- 0.000000,-

0.000000],[1.00000000,0.00000000,0.00000000,0.00000 000]],[[0,0,0],[1,0,0,0]]]; 
 
! -------------------------------------------------  
! Declaration of Tools and Workobjects 
! -------------------------------------------------  
 PERS ToolData 

TOOL_1:=[TRUE,[[0.000000,0.000000,0.000000],[1.0000 0000,0.00000000,0.00000000,0.00000000
]],[0.1,[0.1,0.1,0.1],[1,0,0,0],0.4,0.4,0.4]]; 

 PERS ZoneData z1:=[FALSE,0,0,0,0,0,0]; 
 PERS SpeedData vProcess:=[255,500,5000,1000]; 
 
! -------------------------------------------------  
! Robtarget declaration 
! -------------------------------------------------  
PERS robtarget 

R_1:=[[1699.239016,0.000000,2232.568979],[0.67559,0 .00000,0.73728,0.00000],[0,0,0,0],[9E
+09,9E+09,9E+09,9E+09,9E+09,9E+09]]; 

PERS robtarget R_2:=[[949.922979,652.863979,2280.38 0011],[0.64520,-
0.21863,0.70411,0.20034],[0,0,0,0],[9E+09,9E+09,9E+ 09,9E+09,9E+09,9E+09]]; 

PERS robtarget R_3:=[[756.201029,-869.911015,2280.3 80011],[0.61476,0.30574,0.67089,-
0.28016],[0,0,0,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9 E+09]]; 

PERS robtarget R_4:=[[1849.236965,-461.066008,1865. 038991],[0.30883,0.11582,0.94328,-
0.03792],[0,0,0,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9 E+09]]; 

 
! ------------------------------------------------- ----------- 
! Pathnumber: PATH01 
! ------------------------------------------------- ----------- 
PROC ErProg001() 
 MoveJ R_1,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
 MoveJ R_2,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
 MoveJ R_3,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
 MoveJ R_4,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
ENDPROC 
 
! ------------------------------------------------- ----------- 
!  This procedure is the basic "main" function 
! ------------------------------------------------- ----------- 
 PROC RunER() 
  Init_Trigger; 
  Config_OFF; 
  ErProg001; 
! ErProg002; 
  Config_ON; 
 ENDPROC 
ENDMODULE 

 

Importieren einer ASCII Datei 

 
Tag-Menu > File > Load > Import Tags from ASCII file 
 
Erzeugt aus der ASCII Datei einen neuen Path mit den 
zugehörigen Tag-Punkten 
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Motion Planning und Interpolation 
 

Orientierungs Interpolation bei CIRC Bewegungen 

Die Art und Weise wie die Orientierung auf der Kreisbahn interpoliert wird ist bei verschiedenen 
Roboterherstellern unterschiedlich. So ist es bei einigen Herstellern (z.B. FANUC und Stäubli) möglich die 
vorgegebene Orientierung im Via-Punktes auf der Kreisbahn genau anzufahren.  
 
Mit dem neuen ERPL Befehl  
 
 CIRC_ORI_QUAT_IPO  START_VIAORI_END 
 
kann die Orientierungsart eingestellt werden, wenn CIRC_ORI = QUATERNION zuvor gesetzt wurde. 
 
START_VIA_END – Die Ausrichtung der X-Richtung des Via-Punktes bestimmt die Interpolation der 

Orientierung 
START_END – Die Interpolation der Orientierung wird nur durch die Orientierung im Start und 

Ziel bestimmt. 
START_VIAORI_END – Während CIRC-Interpolation wird auch die Orientierung im Via-Punkt erreicht. 
TANGENTIAL – Die X-Achse wird tangential am Kreisbogen geführt 
FIX – Die Orientierung bleibt unverändert, wobei die Orientierung im Ziel ignoriert wird 
 

Variable Konfiguration „nearest solution“ 

Bei PTP Bewegungen kann eine neue Konfiguration im Ziel vorgegeben werden. Einige Applikationen 
erfordern jedoch, dass die Summe Achswertänderungen zwischen Start und Ziel möglichst klein ist.  
 
Der neue ERPL Befehl 
 
 PTP_CALC_MODE VAR_CONFIG 
 
berechnet diese Achswerte. Im Ziel kann der Roboter eine neue Konfiguration haben. Die gültigen 
Verfahrbereiche werden hierbei berücksichtigt. 
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Simulation, ERPL 
 

Welt-Koordinatensystem 

Das Welt-Koordinatensystem kann nun abgeschaltet werden.  
Die Einstellung wird in der Umgebungsdatei „easy-rob.env“ mit  
 

! World coordinate system 1-Show , 0-Hide 
WORLD_COORSYS 1 

 
gespeichert. 
 
 

Ausgabe „cMotion Data“ 

 
Bei der Motion Data Ausgabe wird die verbleibende 
Zeit bis zum Zielpunkt angezeigt 
 
curr. Time 4.631 [s] of 6.775 [s] [68%] 
 
Die aktuelle Bewegung dauert 6.775s.  
Davon sind 4.631s [68%] bereits vergangen. 
 
Darüber hinaus werden weitere Zustände 
angezeigt, wie programmierte Geschwindigkeiten, 
Beschleunigungen, PTP Calculation Mode etc. 
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Referenz-Kinematik 
 
Redundante Kinematiken und Kinematiken ohne analytische Lösung konnten bisher nur mit einem 
numerischen Lösungsverfahren im kartesischen Raum verfahren werden. Ist man einerseits über diese 
Lösung froh, erweist es sich als Nachteilig, dass der Roboter sich stets nur in einer aktuellen Konfiguration 
bewegt. Ein Umkonfigurieren ist nur umständlich möglich. Mit dem neuen Lösungsverfahren „Referenz-
Kinematik“ können nun alle Konfigurationen angefahren werden 
 
Als Referenz-Kinematik stehen derzeit 
vier kinematische Strukturen der Typen 
- RRR_RRR Rzyy:Rxyx 
- RRR_RRR Rzyy:Rxyx with back link 
- Scara RzzTz:Rz 
- Gantry Txyz:Rzyz 
zur Verfügung. 
 

 
 

 

 

  
 

  
7 Ax-Roboter IA-20 mit Referenz-Kinematik in 
unterschiedlichen Konfigurationen 1 und 3 

 
Die Grundidee besteht darin eine geeignete Referenz-Kinematik zu wählen und entsprechend zu 
parametrisieren, die für verschiedene Konfigurationen Startwerte für das numerische Lösungsverfahren 
vorgibt. 
 
Das Verfahren wurde in Zusammenarbeit mit Hr. Matthias Aalto (GOM - Gesellschaft für Optische 
Messtechnik mbH, Braunschweig, http://www.gom.com) entwickelt. 
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AVI 
 
Beim AVI Recorder können weitere Auflösungen eingestellt werden. Weiterhin lassen sich Menu, Toolbars 
und Statuszeile wegblenden. 
 

 
 
Neue Auflösungen: 
Size 1280 x  720 ,16:9 
Size 1280 x  800 ,16:10 
Size 1568 x  980 ,16:10 
Size 1600 x 1000 ,16:10 
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ERPL-Befehle 
 
 
PTP_CALC_MODE  SHORTEST_ANGLE [TURN, MATH, IN_TRAVEL_RANGE, VAR_CONFIG] 
 
Berechnungsvorschrift bei PTP-Bewegungen 
 
SHORTEST_ANGLE – kürzester Winkel 
TURN – nach TURN-Vorgabe 
MATH – mathematisch innerhalb [-180°,180°] 
IN_TRAVEL_RANGE – innerhalb gültiger Verfahrbereiche wenn möglich 
VAR_CONFIG – variable Konfiguration. Die Berechnung kleinster Achswertänderungen zwischen 

Start und Ziel, kann zu einer neuen Roboterkonfiguration führen 
 
 
CIRC_ORI_QUAT_IPO START_VIA_END [START_END, START_VIAORI_END, TANGENTIAL, FIX] 
 
Orientierungs-Interpolationart für Circular CP Bewegung, wenn CIRC_ORI = QUATERNION gesetzt 
 
START_VIA_END – Die Ausrichtung der X-Richtung des Via-Punktes bestimmt die Interpolation der 

Orientierung 
START_END – Die Interpolation der Orientierung wird nur durch die Orientierung im Start und 

Ziel bestimmt. 
START_VIAORI_END – Während CIRC-Interpolation wird auch die Orientierung im Via-Punkt erreicht. 
TANGENTIAL – Die X-Achse wird tangential am Kreisbogen geführt 
FIX – Die Orientierung bleibt unverändert, wobei die Orientierung im Ziel ignoriert wird 
 
 
 
 

ERCL-Befehle 
 
ERC VIEW TOP [BOTTOM, LEFT, RIGHT, FRONT, REAR, ZOOM_WORLD] 
 
Zoomt die Szene in vordefinierte Perspektiven (Top, Bottom, Left, etc.).  
ZOOM_WORLD zoomt die Szene in den sichtbaren Bereich 
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Kontakt 

 
 
 

EASY-ROB  3D Robot Simulation Tool 
 
Stefan Anton 
Hans - Thoma - Str. 26a, 60596 Frankfurt/Main, Germany 
Tel.  +49 (0) 69  677 24 287 
Fax.  +49 (0) 69  677 24 320 
 
Email: contact@easy-rob.com 
 sales@easy-rob.com 
 
Web: www.easy-rob.com 
 
 

EASY-ROB Kundenbereich 
 
Online verfügbar: Programm-Updates und Roboterbibliotheken 
 
Web: www.easy-rob.com/special/kundenbereich 
 
Zugangsdaten: 

Benutzer: customer 
Passwort: ********** 
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Eigene Notizen 
 
 
 
 


