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EASY-ROB™ V5.6 
 

Highlights in EASY-ROB™ V5.6  
 

• EASY-ROB™ available as 64-Bit version   
The whole EASY-ROB™ Product Suite containing the Single-Robot  and Multi-Program  Version, 
the DLL Version  and the Simulations Kernel  is now available as 64-Bit version. 
This allows you to use the completely available main memory using Window® 7 64-Bit. 
 

• Navigation und operation 
The Center of Interest “COI” relieves navigation through the 3D scene. In the Auto-mode the COI is 
always attached to the current object and forms the cruise center point. 
Additionally you can zoom the current object or the whole world using F8. 
 

• Space Mouse connectivity 
EASY-ROB™ supports the 3D Mouse (Space Mouse) from 3DConnexion. This makes the 
navigation through the three-dimensional robot cell very intuitively and precisely. 
 

• CAD2ER 
The conversion of STEP- and VRML II data into the own IGP-format has been exported as an own 
independent application. It is now available als 32-bit application. 
 

• CAD data export 
Single robots, devices or even the whole work cell can be exported into the binary STL format. STL 
binary is a neutral format and can be imported into all CAD systems. This allows the designer for 
example to process further the results of the planer.  
 

• IGP also as binary Format 
IGP can be saved and read as binary format. The file size will be reduced about 50%. Reading this 
kind of file will save about 20% of time. 
 

• New robots 
New robot models from ABB, Kuka, Stäubli, Fanuc, Motoman and OTC has been added to the robot 
library. 
 

• Paths and tag points 
Paths can now be assigned to robots ( “Path Owner”), which improves the clarity especially using 
large work cells. If you choose a tag, the assigned robot will be selected automatically. 
Tag points of a path will be automatically connected with the according motion type. A visualization 
allows you to recognize immediately how the trace of CP motions (LIN and CIRC) looks like. PTP 
motion for example is visualized as a dashed line. 
Paths can also be exported and imported into different ASCII formats. For ABB Rapid S4 and KUKA 
KRC is a generic export available. This allows you to take over Robtargets from EASY-ROB™ into 
an ABB/KUKA program. We are planning to expand this feature for other languages, e.g COMAU in 
the future. 
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• Motion planning and interpolation 
It is now possible to move to the exact orientation of the given Via-point, as it is known by the 
Stäubli- and Fanuc control. The final configuration (config) of the motion type Synchro-PTP can be 
kept variable. 
The target-angle respectively the axis position with the smallest changes is taken as solution 
(nearest solution). The resulting motion not only looks more elegant, it also can be reached much 
faster. 
 

• Simulation, ERPL 
It is again possible, to interpolate the perspective while the simulation is running. 
Useful ERPL and ERCL commands has been added. 
 

• Reference kinematics 
Redundant kinematics and kinematics without analytical solution could previously only be moved 
with a numerical solution method in Cartesian space. But this is also very disadvantageous  because 
the robot is only able to move within one actual configuration. A reconfiguration is very awkward. 
With the new solution, called “Reference-kinematics” you are now able to move to each 
configuration. 
 

• NC simulation 
The NC Interpreter supports the G-Codes G17, G18 and G19, which sets the plane for circular 
interpolation. 
 

• API Application Program Interface, the class CAPI 
Many new API functions for individual product customization and special solutions has been added. 
These new functions allow to control EASY-ROB™ out of an own application or to exchange data in 
a bidirectional way. 
 

 
The new version is available free of charge for all customers with a valid license key for EASY-ROB™ V5.6. 
For customers using older versions, it will be possible to purchase an update. We would like to thank you for 
your suggestions and ideas in advance. 

 
Thank you 

 
Stefan Anton 

EASY-ROB  
3D Robot Simulation Tool 
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64-Bit Version 
The whole EASY-ROB™ Product Suite containing the Single-Robot  and Multi-Program  Version, the DLL 
Version  and the Simulations Kernel  is now available as 64-Bit Version.  
 
This allows you to use the completely available main memory using Window® 7 64-Bit. Especially for large 
data models this advantage becomes apparent. The 2.2 – 3 GB memory-limit of the 32-Bit version is 
reached very fast. First tests are very promising. Now it is worth again to update your computer with better 
graphics cards or more memory. Although a comparison of the simulation speed between the 32-Bit and 64-
Bit-version shows no significant difference. 

Operation 

The operation has not been changed. The user will recognize no difference between the 32- and 64-Bit 
version. Work cells, robot files and program files can be run in both versions. But we recommend to copy 
your files first. IGP, STL and 3DS files will only be read when the robot or work cell is loaded, so there is no 
need to copy these files.  

API 

The programming interface remains also unchanged in the 64-Bit version. Some projects have to be 
converted to 64-Bit and compiled once again. Don’t forget the preprocessor definition „_WIN64“, see also 
“/er_dvlp/ ER_CAPI_TYPES.H“. At the end the EASY-ROB™ Library „easyrobwx64.lib” has to be linked. 
We have decided to provide each 64-Bit Dlls with the Postfix x64. So „easyrobw.exe” becomes 
„easyrobwx64.exe” and „er_tbox.dll” becomes „er_tboxx64.dll“. 

Exceptions 

1. AVI movies cannot be created in the actual 64-Bit version. This feature will be added in the 
upcoming updates. 
 

2. The “older” collision-algorithm OpCode could not be added to the 64-Bit-version. The “newer” 
and also more powerful collision-algorithm, which is available since version 5.3 has been added 
instead. 
 

 
 
 



 

 The right is reserved to make technical changes and improvements 8/28 
  
EASY-ROB™ Stefan Anton Hans-Thoma-Str.26a 60596 Frankfurt/Main Germany Tel. +49 69 677 24-287  Fax. +49 69 677 24-320  info.er@easy-rob.com  www.easy-rob.com 
 

 
 Update EASY-ROB™ V5.6 
 

Navigation and operation 
 
Operation and navigation has been improved in the new version. 
 

• All dialogues have been provided with Tool Tips: a short description appears if you remain on the 
buttons in the dialogue for a while. 

 
 

• The entire Menu bar can be hidden 
Menu: View > Menu  F10 
Pressing F10 will show the Menu bar again 
 

• Users, working with different 3D Software Tools (CAD systems, etc.), can now change the 

assignment of keys for the Cruise Mode   using the environment file (Alt+Shift+E) „easy-
rob.env“. 
 
Applies for EASY-ROB™: 
CRUISE_ROT_FLAGS  LMB press LMB to rotate the world 
CRUISE_ZOOM_FLAGS     MMB press MMB to zoom in or out 
CRUISE_ZOOM2MB_FLAG   RMB zoom setting if '2 Mouse Buttons' is enabled 
CRUISE_PAN_FLAG      LMB  RMB press LMB+RMB to pan the world 
 
The basic settings can be restored in the Menu: View > Set 3D View > Reset Cruise Flags 
 
Hint: 
Sample-settings will be created after saving the environment file. 
 

 

Center of Interest COI 

The COI of the 3D scene will be set automatically using the Cruise Mode Auto (Standard setting). This 
happens if you pick a geometry, a robot, tag, polygon or e.g. a vertex. Pressing the F8 will zoom the COI to 
the center of the screen. 
 
The COI is visualized as a small and transparent 
red ball  . It also can be switched off in the 
Navigator Window. 

 

 
COI in the world origin 
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Zoom 

The new Zoom function simplifies the moving of selected objects into the visible area of your screen. The 
rotation of the 3D scene around the center of these objects has been improved, too. 
 
 
The whole 3D scene, the cRobot, cTag etc. can be zoomed into the center of 
your screen by using the Menu View > Set 3D View > Zoom 
 
 
 
1. Example: 

Load a robot and open the 3D CAD Window by clicking twice on  

Choose a geometry by clicking on   
Press the F8 button or use the Menu: Zoom cBody. 
The selected geometry will be zoomed into the center of the screen and is now 
the Center of Interest (COI). 
 
 
Hint: 
Pressing the space-bar changes between the “Pick“- and “Cruise“ modes. 
 
 
2. Example:  
Pick a vertex of a geometry, so that the chosen vertex becomes the COI. For 
that open the Navigator Window (Ctrl + N) 
 
Select: 
Point Measure and Vertices and 

 
and „pick“ a vertex of the geometry. 
 
Press now F8, and the selected vertex, 
which now is the Center Of Interest 
(COI), will be zoomed to the center of 
the screen. 
 

 

 
 

 

 
View > Set 3D View > Zoom 
 

 
The COI  has been placed in 
the center of the selected 
geometry 
 

The COI  has been placed 
on the selected vertex of the 
geometry 
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Measuring of the center-circle 

 
Since version 5.3 the circle center can be determined by measuring three points of the circle. In the new 
version measured values, as radius, arc length and angle will be displayed additionally. 
 
 
 
Select 3 Point Circle Measure and Vertices and 

 in the Navigator Window. Pick three points of 
your geometry. 
 
The order of the measuring points determines the normal 
vector and the direction of the arc. 
 

 
 

      
1. Measuring point 2. Measuring point 3. Measuring point 
  Result: R= 80, Phi= 124°, Arc=  173 
 
Hint: 
Press the Esc button, if you have selected a wrong vertex. It will be deleted. To create a new tag point in the 
center circle press the MMB once and after that the RMB. 
 

Visualization of coordinate systems 

 
Coordinate systems, such as used for tags will be 
visualized in a new way, to prevent them from covering e.g. 
geometry-points. 
 
The origin of the coordinate system is cut free, which 
allows you to select points/vertices more clearly. 
 
Furthermore the size of the tags will be regulated while 
zooming. 
 

 
New coorsys visualization 
 

 
 
  



 

 The right is reserved to make technical changes and improvements 11/28 
  
EASY-ROB™ Stefan Anton Hans-Thoma-Str.26a 60596 Frankfurt/Main Germany Tel. +49 69 677 24-287  Fax. +49 69 677 24-320  info.er@easy-rob.com  www.easy-rob.com 
 

 
Update EASY-ROB™ V5.6 
 

Near- and Farplane 

The setting of Near- and Far Plane (Clipping Planes) can be done interactively by dragging the mouse. 
 
Select Menu Mouse Mode > Near Far Plane 
in the Navigator Window. 
 
Drag the mouse holding the  
LMB to move the Near Plane or 
RMB to move the Far Plane. 
 
Alternative: Insert the values using the Menu: 
View > Graphic View Data 
 

 

 
 
 

 

 
 

 

 
 

Floor and Background Color 

 
Floor and Background color can be set directly in the Color-Dialogue. 
 
Menu View >Floor  > Floor Color 
Menu View >Render > Background Color 
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Space Mouse connectivity 
Navigate through the 3D scene using the Space Mouse from 3DConexion. 
This makes the navigation through the three-dimensional robot cell very intuitively and precisely. 
 
 

  
 Picture: 3DConnexion 
 
Key assignment of the Space Explorer (see also display of Status Bar) 
 

 
1  Toggles  -> PanZoom  

 -> Rotate  
 -> Pan+Rotate 

 
2  Toggles  -> Cruise World  

 -> Jog cTcp  
 -> Jog cRobot Joints 

 
Shift  as Keyboard 
Esc  as Keyboard 
Ctrl   as Keyboard 
Alt   as Keyboard 
 

 

 
-   Reduces sensitivity 
 
+   Increases sensitivity 
 
 
T  Top View 
L  Left View 
2D  without function 
R  Right View 
F  Front View 
 
 

 Panel  Open Menu 
Fit   Zoom World, cRobot, cTag, .. 
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CAD2ER 
STEP- and VRML II, 97 data can be converted into IGP using EASY-ROB™ - CAD2ER. The application has 
been exported as an independent application which can be found in the folder ./cad2er/ der EASY-ROB™ 
Applikation. Opened Rob- and IGP-files will be loaded in a new EASY-ROB™ session. 
 
Start  CAD2ER with the keyboard shortcut “Ctrl+Shift+C” or using the Menu: Load > Start CAD2ER 
Converter 
 

 
CAD2ER was created in collaboration with machineering GmbH & Co. KG (www.machineering.de). 
machineering develops software solutions for the 3D-Simulation and virtual start-up in machinery and equipment. 

 
 
Operation 

• Select the file you want to convert by clicking on  . 
• Change the name of the output file „Output File“ if necessary 
• Check the „User Color” to set the color afterwards in EASY-ROB™. 

• Press  to start conversion 
• Double click on the created filename in the „[]“ brackets to open it in a new EASY-ROB™ session. 

• Quit CAD2ER with  
 

Hint: Native CAD files, as CATIA V4/V5 or Pro/Engineer, can be converted to STEP using the software 
„3D-Tool“. 
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CAD data export 
 
Single robots or devices or even the whole work cell can be exported into the binary STL format. STL binary 
is a neutral format and can be imported into all CAD systems. So the results of the planer can be further 
processed by the designer.  
 
Optionally, the exported STL format can include also color attributes, which is unfortunately not supported 
by every CAD system. 
 
 

 
work cell: arcweld_L_01.cel 

For export choose the robot and open the CAD 
Export Window  by clicking on Menu: File > Save 
> Export > STL binary. 
 

 
 

Choosing „cDevice with childs“ will export the 
robot including the torch as colored STL-file, e.g. 
DeviceChilds_stl“. 

   
Robot al STL binary file Turn-table as IGP binary file 

 
work cell as VRML II,97 file 

 
To export e.g. the turn-table „POSITIONER_01“ 
including its component „WORKPIECE_02 „ as 
IGP binary file, select only the turn-table. 
 

 
 
IGP can be saved and read as binary format. The 
file size will be reduced about 50%. Reading this 
kind of file will save about 20% of time. Each 
geometry will be saved in world coordinates. 
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IGP also as binary format 
 
IGP can be saved and read as binary format. The file size will be reduced about 50%. Reading this kind of 
file will save about 20% of time.  
 
IGP binary b11 consists only of triangulated data. 
 
Structure of the format 
 
 IGPHeader 80 bytes "b11 EASY-ROB IGP binary Export er v1.0 ..."; 
   --> detection key 'b11' -> binary and version 11  
 
 OBJHeader 16 Bytes int n_coorsys int n-obj 0 0 
 
 if (n_coorsys) 
   OBJ_COORSYS 48 Bytes float n[3],o[3],a[3],p[3] 
 
 if (n_obj) 
   OBJHeader 16 Bytes int color_idx n_points n_line s n_poly 
 
 read complete object content, with  
  n_obj_size = n_point*sizeof(VERTEX)+ n_line*sizeo f(LINESEG)+  
   n_poly*sizeof(TRIPOLY); 
  --> obj_content 
 if (n_points>0) get vertices from obj_content 
 if (n_lines>0)  get lines from obj_content 
 if (n_poly>0) get triangulated polygons from obj_c ontent 
 
 go for next object 

 
with the data types: 
 

typedef  struct  { char  id[80]; } IGPHeader;   // 80 Bytes  
typedef  struct  { int  iv[4]; // n_coorsys n-obj 0 0 ;  
  or color_idx n_points n_lines n_poly  
  } OBJHeader;   // 16 Bytes  
typedef  struct  { float  n[3],o[3],a[3],p[3]; } OBJ_COORSYS;  // 48 Bytes  
typedef  struct  { float  x[DIM]; } VERTEX;  // 12 Bytes  
typedef  struct  { int  l[2]; } LINESEG;   // 8 Bytes  
typedef  struct  { int  i[3]; } TRIPOLY;   // 12 Bytes  
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New robots 
 
The robot library has grown. New models form ABB, Kuka, Stäubli, Fanuc, Motoman and OTC have been 
added. 
 
Some examples 
 
ABB robots 
 

IRB-120-3-0,6.rob 
IRB-260--30-M2004.rob 
IRB-540-12-10.rob 
IRB-540-1620-M96.rob 
IRB-6660_205_190.rob 

 

  
IRB-260--30-M2004 IRB-6660_205_190 
 

COMAU robots 
 

SM-NH3-165-3,0.rob 
SM-NH3-220-2,7.rob 
SM-NM-16-3,1.rob 

 

  
SM-NM-16-3,1 SM-NH3-165-3,0 
 

KUKA robots 
 

KR180L100_2k.rob 
KR180L100K_2K.rob 
KR360-2 
KR360-L280 
KR360-L240 
KR500-2 
KR500-L420 
KR500-L340 
KR90-R2700-pro 
KR90-R3100-extra 

 

  
KR-500-L420-- KUKA-LBR.jpg 
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New robots 
 
 
OTC-Daihen robots 
 

AII-B4.rob 
AII-B4L.rob 
AII-PF-XXX.rob 
AII-PH-501.rob 

 

  
AII-B4 AII-PH-501 

 
Staubli robots 
 

CS8-Controller.rob 
CS8-PENDANT.rob 
CS8-STOP.rob 
TS40-STD-FL.rob 
TS60-STD-FL.rob 
TS80-STD-FL.rob 
TX200--100-.rob 
TX200-L-60-.rob 

 
  

TX200-L-60- TS60-STD-FL 

 
Schunk robots 
 

LWA3 - Ultra Light Weight  
  Arm Version 3 
 

 
LWA3.jpg 
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Paths and tag points 
 

Path Owner 

Paths can now be assigned to robots ( “Path Owner”), which improves the clarity especially using large work 
cells. If you choose a tag, the assigned robot will be selected automatically. 
 
 
By double-clicking on “Path Owner” in the Tag 
Window you can choose the robot, which refers to 
the path. Here it is the “ER431”. 
 

 
 

 
 
The connection can also be dissolved again. 
 

 

 
 
 

Motion Type Visualization 

If a tag point is assigned to a “motion type” as PTP, LIN, VIA or CIRC this state is represented graphically. 
 

 

Motion Type not defined , dark dashed line 

 

Motion Type PTP, yellow dashed line 

 
Motion Type CP LIN, yellow solid line 
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Motion Type CP VIA -> CIRC, yellow solid line 

 

Motion Type invalid , red solid line 
 
e.g. two tags with the motion type CIRC follow 
each other. 

 
Path with different motion types 

 
Path with changed T_Via position, the circular 
segment will immediately be updated. 

Path Export 

Paths can now be exported into different ASCII formats. They can also be imported again. 
Tag-Menu > File > Save > Export cPath 
 
The first four variations save all tag positions of the 
current path “cPath” as 
1. xyz ijk 

0.00 0.00 700.00  0 0 -1 T_PTP 
600.00 0.00 700.00  0 0 -1 T_LIN 

2. xyz RxRyRz 
0.00 0.00 700.00  180 0 0 T_PTP 
600.00 0.00 700.00  180 0 0 T_LIN 

3. xyz RxRyRz + Tag-Attributes   
[motype, render, speed_ptp_ov, speed_cp, speed_ori, 
configuration] 
0.00 0.00 700.00  180 0 0 T_PTP  
 0 0.0000 0.0000 0.0000 0 
600.00 0.00 700.00  180 0 0 T_LIN  
 2 0 0.0000 0.0000 0.0000 0 

 
 

 



 

 The right is reserved to make technical changes and improvements 20/28 
  
EASY-ROB™ Stefan Anton Hans-Thoma-Str.26a 60596 Frankfurt/Main Germany Tel. +49 69 677 24-287  Fax. +49 69 677 24-320  info.er@easy-rob.com  www.easy-rob.com 
 

 
 Update EASY-ROB™ V5.6 
 
 
4. xyz noa Frame 

0.00 0.00 700.00  1 0 0  0 -1 0  0 0 -1  T_PTP 
600.00 0.00 700.00  1 0 0  0 -1 0  0 0 -1  T_LIN 

 
Such ASCII files can also be created by external applications, so that end positions as measuring points, etc 
can be imported as paths in EASY-ROB™. 
 
The variation „5 – EASY-ROB Program ” writes out an ERPL program for the cPath. Here the target 
positions are written out as numbers with respect to the robot base. 
 

ProgramFile 
! 
SPEED_PTP_OV   80.0000 
SPEED_CP_OV    80.0000 
SPEED_ORI_OV   80.0000 
OV_PRO   100.0000 
ERC NO_DECEL OFF 
ZONE   0.0000 
! 
ERC TRACK ON 
! 
BASE 1.3228 0.2826 0.0500 0.00000 0.00000 0.00000 
! 
TOOL 0.0000 0.0000 0.0000 0.00000 0.00000 0.00000 
! 
PTP   0.00000 0.00000 0.70000 180.000 0.000 0.000 
LIN   0.60000 0.00000 0.70000 180.000 0.000 0.000 
! 
EndProgramFile 

 
Variation „6 - FAMOS Point Data “ exports a Point Data file for the OLP Software FAMOS robotic®. These 
Point Data files (*.pis) can also be generated by FAMOS and imported into EASY-ROB™. 
 

Syntax einer .pis Datei: n o a p 
1 1 1 0 1 0 0 0 1 0 0 0 
-0.0871558 0.0000000 -0.9961947 0.0000000 1.0000000  0.0000000 0.9961947 0.0000000 -0.0871558 

1699.239 0.000 2232.569 
-0.0718273 -0.0493656 -0.9961947 -0.5664063 0.82412 62 -0.0000001 0.8209901 0.5642509 -

0.0871557 949.923 652.864 2280.380 
-0.0571793 0.0657772 -0.9961947 0.7547101 0.6560584  -0.0000001 0.6535619 -0.7518381 -0.0871557 

756.201 -869.911 2280.380 
-0.7824137 0.1950773 -0.5914166 0.2419214 0.9702958  0.0000000 0.5738491 -0.1430763 -0.8063661 

1849.237 -461.066 1865.039 

 
The variations „7 - ABB Rapid Program “ and „8 - KUKA KRL Program “ allow to create a generic exports 
for ABB Rapid S4 and KUKA KRC. This allows you to take over “robtargets” from EASY-ROB™ into an 
ABB/KUKA program. We are planning to expand this feature for other languages, e.g COMAU in the future. 
  

Example ABB Rapid Export 
%%% 
  VERSION:1 
  LANGUAGE:ENGLISH 
%%% 
MODULE MY_PROG 
! -------------------------------------------------  
! Path Export 
! EASY-ROB 3D Robot Simulation Tool 
! Copyright (c) 1996-2011 
! -------------------------------------------------  
! -------------------------------------------------  
! Declaration of common variables 
! -------------------------------------------------  
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 PERS LoadData lDef:=[10,[0,0,0.1],[1,0,0,0],0,0,0] ; 
 PERS ZoneData zDef:=[FALSE,0,0,0,0,0,0]; 
 PERS SpeedData vDef:=[0.05,500,5000,1000]; 
 
 PERS WobjData WOBJ01:=[FALSE,TRUE,"",[[-0.000000,- 0.000000,-

0.000000],[1.00000000,0.00000000,0.00000000,0.00000 000]],[[0,0,0],[1,0,0,0]]]; 
 
! -------------------------------------------------  
! Declaration of Tools and Workobjects 
! -------------------------------------------------  
 PERS ToolData 

TOOL_1:=[TRUE,[[0.000000,0.000000,0.000000],[1.0000 0000,0.00000000,0.00000000,0.00000000
]],[0.1,[0.1,0.1,0.1],[1,0,0,0],0.4,0.4,0.4]]; 

 PERS ZoneData z1:=[FALSE,0,0,0,0,0,0]; 
 PERS SpeedData vProcess:=[255,500,5000,1000]; 
 
! -------------------------------------------------  
! Robtarget declaration 
! -------------------------------------------------  
PERS robtarget 

R_1:=[[1699.239016,0.000000,2232.568979],[0.67559,0 .00000,0.73728,0.00000],[0,0,0,0],[9E
+09,9E+09,9E+09,9E+09,9E+09,9E+09]]; 

PERS robtarget R_2:=[[949.922979,652.863979,2280.38 0011],[0.64520,-
0.21863,0.70411,0.20034],[0,0,0,0],[9E+09,9E+09,9E+ 09,9E+09,9E+09,9E+09]]; 

PERS robtarget R_3:=[[756.201029,-869.911015,2280.3 80011],[0.61476,0.30574,0.67089,-
0.28016],[0,0,0,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9 E+09]]; 

PERS robtarget R_4:=[[1849.236965,-461.066008,1865. 038991],[0.30883,0.11582,0.94328,-
0.03792],[0,0,0,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9 E+09]]; 

 
! ------------------------------------------------- ----------- 
! Pathnumber: PATH01 
! ------------------------------------------------- ----------- 
PROC ErProg001() 
 MoveJ R_1,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
 MoveJ R_2,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
 MoveJ R_3,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
 MoveJ R_4,vProcess,fine,TOOL_1\WObj:=WOBJ01; 
ENDPROC 
 
! ------------------------------------------------- ----------- 
!  This procedure is the basic "main" function 
! ------------------------------------------------- ----------- 
 PROC RunER() 
  Init_Trigger; 
  Config_OFF; 
  ErProg001; 
! ErProg002; 
  Config_ON; 
 ENDPROC 
ENDMODULE 

 

Import of ASCII data 

 
Tag-Menu > File > Load > Import Tags from ASCII file 
 
Creates a new path with its associated tags out of an 
ASCII file. 
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Motion planning and Interpolation 
 

Interpolation of orientation in CIRC motion 

The manner in which the orientation is interpolated differs from manufacturer to manufacturer.  
Some manufacturer (e.g. FANUC and Stäubli) make it possible to move to the exact orientation of the given 
Via-point on the circle-segment. 
 
The orientation type can be set with the new ERPL command  
 
 CIRC_ORI_QUAT_IPO  START_VIAORI_END 
 
, if CIRC_ORI = QUATERNION has been set before. 
 
START_VIA_END – The orientation of the x-direction of the Via-point determines the interpolation of  

the orientation. 
START_END – The interpolation of the orientation will be only determined by the orientation at 

start and end position. 
START_VIAORI_END – While CIRC-interpolation the orientation will be reached at the Via-point. 
TANGENTIAL – The x-axis will be guided tangentially on the circular arc. 
FIX – The orientation remains unchanged. The orientation at the target position will be 

ignored. 
 

Variable configuration „nearest solution“ 

A new configuration at the target position can be set for PTP motion. However some applications require the 
sum of axis value changes between the start and target position to be as low as possible. 
 
The new command 
 
 PTP_CALC_MODE VAR_CONFIG 
 
calculates these axis values. The robot can possibly have a new configuration at the target position. The 
valid travel ranges will be considered here. 
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Simulation, ERPL 
 

World coordinate system 

The world coordinate system can now be switched off. 
You can make this setting in the environment file „easy-rob.env“:  
 

! World coordinate system 1-Show , 0-Hide 
WORLD_COORSYS 1 

 
 
 

Output „cMotion Data“ 

 
The Motion Data Output shows the remaining time 
until the target point is reached. 
 
curr. Time 4.631 [s] of 6.775 [s] [68%] 
 
The current motion takes 6.775s.  
Of which 4.631s [68%] are already have passed. 
 
In addition, other states, as programmed velocities, 
accelerations, PTP Calculation Mode, etc, are 
displayed. 
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Reference kinematics 
Redundant kinematics and kinematics without analytical solution could previously only be moved with a 
numerical solution method in Cartesian space. But this is also very disadvantageous  because the robot is 
only able to move within one actual configuration. A reconfiguration is very awkward. With the new solution, 
called “Reference-kinematics” you are now able to move to each configuration. 
 
Four kinematics structure types are 
actually available as reference kinematics: 
 
- RRR_RRR Rzyy:Rxyx 
- RRR_RRR Rzyy:Rxyx with back link 
- Scara RzzTz:Rz 
- Gantry Txyz:Rzyz 
 

 
 

 

 

  
 

  
7 Ax-Roboter IA-20 with reference-kinematics in different 
configurations 1 and 3 

 
 
The main idea is to choose an appropriate reference-kinematics, which supports us with start values for the 
numerical solution for each configuration. 
 
This method was developed in collaboration with Mr. Matthias Aalto (GOM - Gesellschaft für Optische 
Messtechnik mbH, Braunschweig, http://www.gom.com). 
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AVI 
New resolutions can be set in the AVI Recorder. Furthermore the Menu, toolbars and status line can be 
hidden. 
 

 
 
New resolutions: 
Size 1280 x  720 ,16:9 
Size 1280 x  800 ,16:10 
Size 1568 x  980 ,16:10 
Size 1600 x 1000 ,16:10 
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ERPL commands 
 
 
PTP_CALC_MODE  SHORTEST_ANGLE [TURN, MATH, IN_TRAVEL_RANGE, VAR_CONFIG] 
 
Calculation rule for PTP-motion 
 
SHORTEST_ANGLE – Shortest angle 
TURN – as TURN 
MATH – mathematically within [-180°,180°] 
IN_TRAVEL_RANGE – within valid travel range, when possible  
VAR_CONFIG – variable configuration. The calculation of axis values changes between the start 

and target position can result in a new robot configuration. 
 
 
CIRC_ORI_QUAT_IPO START_VIA_END [START_END, START_VIAORI_END, TANGENTIAL, FIX] 
 
Orientation-Interpolation for Circular CP motion, if CIRC_ORI = QUATERNION is set. 
 
START_VIA_END – The orientation of the x-direction of the Via-point determines the interpolation of  

the orientation. 
START_END – The interpolation of the orientation will be only determined by the orientation at 

start and end position. 
START_VIAORI_END – While CIRC-interpolation the orientation will be reached at the Via-point. 
TANGENTIAL – The x-axis is guided tangentially on the circular arc. 
FIX – The orientation remains unchanged. The orientation at the target position will be 

ignored. 
 
 
 
 

ERCL-Befehle 
 
ERC VIEW TOP [BOTTOM, LEFT, RIGHT, FRONT, REAR, ZOOM_WORLD] 
 
Zooms the scene into the predefined perspective (Top, Bottom, Left, etc.).  
ZOOM_WORLD zooms the scene into the visible area of the screen. 
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Contact 

 
 
 

EASY-ROB  3D Robot Simulation Tool 
 
Stefan Anton 
Hans - Thoma - Str. 26a, 60596 Frankfurt/Main, Germany 
Tel.  +49 (0) 69  677 24 287 
Fax.  +49 (0) 69  677 24 320 
 
Email: contact@easy-rob.com 
 sales@easy-rob.com 
 
Web: www.easy-rob.com 
 
 

EASY-ROB Customer area 
 
Online available: Program Updates and Robot libraries 
 
Web: www.easy-rob.com/special/kundenbereich 
 
Access data: 

User: customer 
Password: ********** 
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